Allow change in Live Bookmark refresh rate/interval

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
14 years ago
9 years ago

People

(Reporter: Casey Weston, Unassigned)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040922 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040922 Firefox/0.10

After FF 1.0PR came out I tried the new Live Bookmark functionality on some of
my favorite websites.  2 of them were slashdot.org and games.slashdot.org. I
left them on my Bookmark Toolbar. It worked okay until today when it told me I
was banned from the RSS Feed server because Firefox kept asking for updates too
frequently, slamming their servers.  

Reproducible: Always
Steps to Reproduce:
1. Subscribe to slashdot.org's RSS feed
2. Use Firefox 1.0PR for a week or more
3. Get banned from RSS feed

Actual Results:  
Got banned from RSS feed.

Expected Results:  
Allow me to tell Firefox how frequently to check for updates.

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

14 years ago
Vlad added a hidden pref for this at 2004-10-02 17:17.  I'm not marking it as
fixed because the pref is hidden.
Summary: Allow change in Live Bookmark refresh rate → Allow change in Live Bookmark refresh rate/interval
adding a UI pref isn't necessarily the answer here.  I could easily, very
easily, see users crank it down to a fast refresh, not realizing the consequences.

What is the actual slashdot limit? 30 minutes? one hour?
I'll probably add the "hidden" pref to the about:config list, and leave it at
that.  Note that the actual refresh rate is the max of: the cache expiry time
that the server sends back, the user specified value, and 5 minutes (I think 5
minutes, can't remember atm).  So someone cranking the value way down will
probably go under the server's cache expiry time setting.

Comment 4

14 years ago
Gmail has just added an ATOM feed, allowing me to get a list of my new messages.
Why is it relevant? Because I want the Gmail feed to refresh faster than, say,
the slashdot feed. I want to check for new mail every 2 minutes, but for new
headlines only after 10.
So what I'm saying is, the refresh rate should not be a hidden pref, or a pref
at all. It should be a property of any live bookmark ("Refresh this feed every
[...] minutes".
(Reporter)

Updated

14 years ago
Flags: blocking-aviary1.0+
(Reporter)

Updated

14 years ago
Flags: blocking-aviary1.0+ → blocking-aviary1.0?
(In reply to comment #4)
> the slashdot feed. I want to check for new mail every 2 minutes, but for new
> headlines only after 10.

Yep, that's why it's a hidden pref. If the cache wasn't there with a
max-age=1800 to stop you from actually updating more than every 30 minutes,
you'd get yourself banned from Slashdot's feed within a few hours.

Vlad: I just checked through my set of aggregators, and only one will go below
15 minutes, two won't go below 30 (most have a set of choices like 15, 30, 45,
60, 90, 120, 180). Your minimum is currently 1 minute, and I worry that you are
counting too heavily on caching headers to survive that: most RSS feeds are
produced by guess and by golly, with crappy headers and bad in-band information
in things like ttl and skipHours hoping to make up for it. Even with good
headers, all it takes is a few cache-emptying crashes or overflows to turn you
into a bad citizen.

The reason most don't go any lower than they do is partly because they're
written by people who've paid the bandwidth bill for RSS feeds, but mostly
because when they start shipping a version that will fetch once a minute, RSS
producers have made it clear that their user agent will be banned if they don't
stop. When your user agent is Firefox rather than BillyBobsBigAggregator, that's
scary.

Comment 6

14 years ago
(In reply to comment #5)
> (In reply to comment #4)
> > the slashdot feed. I want to check for new mail every 2 minutes, but for new
> > headlines only after 10.
> 
> Yep, that's why it's a hidden pref. If the cache wasn't there with a
> max-age=1800 to stop you from actually updating more than every 30 minutes,
> you'd get yourself banned from Slashdot's feed within a few hours.

I agree about "regular" feeds, but what happens when the feed is something like
the above Gmail feature, or another webmail service? Google's Gmail Notifier
checks for new messages every 2 minutes, so I guess they won't mind if I refresh
my feed every 2 minutes.
But if the limit is global, I can't do that; I don't want to be banned from
slashdot, but I still want new mail checking every 2 minutes.
This won't be fixed in time for 1.0, sorry; after that, the plan is to tie live
bookmark refreshes in with the (currently disabled) bookmark scheduling stuff.
Target Milestone: --- → After Firefox 1.0
*** Bug 268857 has been marked as a duplicate of this bug. ***
Assignee: vladimir → vladimir+bm
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → Trunk
Assignee: vladimir+bm → nobody

Comment 9

13 years ago
In addition to adding individualized refresh settings for live, I think it would be nice to see a "Refresh Live Bookmarks" option in FF's Bookmarks menu which would allow the user to refresh all of the live bookmarks simultaneously.

Comment 10

12 years ago
Seconded. Comment 9 is right on the mark, too. I'm not even confident some of my bookmarks refresh, since the interval isn't public on the user-level.
QA Contact: mconnor → bookmarks
*** Bug 349081 has been marked as a duplicate of this bug. ***
we have browser.bookmarks.livemark_refresh_seconds, so unless i'm losing something this is WFM.
And since we have not seen reports of bans sounds like current defaults are fine, exposing this in UI would only make this worst, i agree with comment 2.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME

Comment 13

9 years ago
I still don't see individualized refresh settings in FF (see above comments); is there a different bug for that?
what do you mean by "individualized"? one for each feed? I can't see a reason for that, sounds like unnecessary complication to solve a problem that actually does not happen.
You need to log in before you can comment on or make changes to this bug.