Turn off Profile:Roaming for 1.8a4 release?

RESOLVED WONTFIX

Status

Core Graveyard
Profile: Roaming
--
blocker
RESOLVED WONTFIX
14 years ago
2 years ago

People

(Reporter: marcia, Assigned: marcia)

Tracking

Trunk
All
Mac OS X
Bug Flags:
blocking1.8a4 -

Firefox Tracking Flags

(Not tracked)

Details

Asa asked me to file this bug as a blocker. Need to possibly turn this off for
the upcoming 1.8a4 release. This feature has not been tested and we may not want
to introduce anything new for this release.

Adding pete zha to this bug, as Asa indicated he was involved with maintaining
this area. Pete: Is it possible that we can enable this only in Solaris builds?
(Assignee)

Comment 1

14 years ago
nominating for blocking 1.8a4
Flags: blocking1.8a4?

Comment 2

14 years ago
If it hasn't been a part of our primary installer builds for windows and linux,
I'm not at all enthusiastic about shipping this in 1.8a4. Shipping it in only
some builds or some platforms is also a bad idea. 
Flags: blocking1.8a4? → blocking1.8a4+

Comment 3

14 years ago
> Adding pete zha to this bug, as Asa indicated he was involved with maintaining
> this area. Pete: Is it possible that we can enable this only in Solaris builds?
It's not necessary since Roaming has a bug will crash when uploading. So, this
feature is still under developing.

Many people has tested it and filed bugs in roaming module, but we haven't got
any test report. asa, where we can upload test report and announce it's being
tested?

Comment 4

14 years ago
Pete, I'm not sure what you mean by test report.  I am concerned that if this
has a known crasher on uploading, that it will not be worth shipping in 1.8a4.
Can we disable the feature until it is working better?

Comment 5

14 years ago
(In reply to comment #4)
> Pete, I'm not sure what you mean by test report.  I am concerned that if this
> has a known crasher on uploading, that it will not be worth shipping in 1.8a4.
> Can we disable the feature until it is working better?
The crash I mentioned is known as bug 244549 and it's only on unix platform can
not always be reproduced. So, this feature works well on non-unix platform. And
sometime will crash when mozilla existing on unix platform.
What do you mean by disabling it? It's not in the installer build due to bug 244770.

Comment 6

14 years ago
It appears that it is in some of the builds we ship for milestones, including
Mac and maybe more. We shouldn't ship the feature in some builds and not in
others. Is there a compile-time option to disable it so that it won't appear in
any of the builds we ship for 1.8a4?

Comment 7

14 years ago
We add this feature into MOZ_EXTENSIONS_DEFAULT in configure. So, we can not
disable it with any switch. But we can remove "sroaming" from the
MOZ_EXTENSIONS_DEFAULT to disable it.

Comment 8

14 years ago
(In reply to comment #7)
> We add this feature into MOZ_EXTENSIONS_DEFAULT in configure. So, we can not
> disable it with any switch. But we can remove "sroaming" from the
> MOZ_EXTENSIONS_DEFAULT to disable it.

--enable-extensions=default,-sroaming

does the trick.

Updated

14 years ago
Flags: blocking1.8a4+ → blocking1.8a4-

Comment 9

13 years ago
Can someone close this bug as WONTFIX?
1.8a4 is out of the door and no more, while SeaMonkey ships Roaming Profiles on
all platforms.

Comment 10

13 years ago
WONTFIX based on last comment
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.