[BLOCKER] Viewer asserts/hangs during regression tests

VERIFIED FIXED in M14

Status

()

Core
Document Navigation
P1
blocker
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: karnaze (gone), Assigned: travis)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

(Reporter)

Description

18 years ago
When running the table regression tests, Viewer asserts and after continuing, it 
hangs. To run the regression tests on Windows, map your s drive to the 
directory above mozilla, go to layout\html\tests\table\core and run "rtest 
baseline". It also fails in any of sibling directories of core (e.g. bugs, 
viewer_tests, marvin, dom, other).

Comment 1

18 years ago
Travis, is this our bug?
Priority: P3 → P1
Target Milestone: M14
(Assignee)

Comment 2

18 years ago
OK, I have put all the infrastructure in place to enable viewer to be a 
embedding client.  It properly sets itself up as a docshellTree Owner and will 
eventually set itself up with the same object as a webBrowser owner.  Much of 
the implementation in this new object is actually stubbed out with assertions 
because much of it is not called yet.  As I start calling them I'll hook things 
up.  If I have missed anything on this pass (I tried going to many sites and 
loading most the tests) then let me know of the assertion that is firing in 
nsWebBrowserChrome and I'll hook it up.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 3

18 years ago
Putting on PDT+ list in case this reopens.  This is dogfood to developers.

Karnaze, can you mark verified now if all is well :-)  Thanks!
Keywords: dogfood
Whiteboard: [PDT+]
(Reporter)

Comment 4

18 years ago
This is fixed now. 
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.