If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

attachment content-type detection relies only on MIME Content-Type field

RESOLVED DUPLICATE of bug 108186

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 108186
13 years ago
13 years ago

People

(Reporter: Noam Tamim, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)
Build Identifier: version 0.8 (20040913)

We've got here messages with PDF attachments. The MIME Content-Type field marks 
the PDFs as application/octet-stream instead of application/pdf (these messages 
are machine generated). But the attachments DO have a PDF extension.
Thunderbird ignores the extension, and (partly) treats the file as of unknown 
type:
1. It is not possible to save the default (double-click) action for those file 
(I want to always open them with acrobat reader).
2. They have no acrobat icon.
3. Here comes the "partly" type - because Windows uses extensions for managing 
associations, the default open application is correct - acrobat reader. But 
the "do this automatically.." checkbox is disabled.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

13 years ago
Just wanted to add, that after using the "do this automatically.." checkbox for 
an attachment that was marked correctly, it is now the default action.

Comment 2

13 years ago
Note that duplicate has been resolved WontFix -- this change will not be made.

*** This bug has been marked as a duplicate of 108186 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.