Can't find text that's in an editable field (i.e. in Wikipedia)

RESOLVED DUPLICATE of bug 252371

Status

()

defect
RESOLVED DUPLICATE of bug 252371
15 years ago
11 years ago

People

(Reporter: tempshill, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10

When I hit ctrl-F and start typing a word to find it on the page, the word will
never be found if it is text that is in an editable field.


Reproducible: Always
Steps to Reproduce:
1. Go to a Wikipedia page, like http://en.wikipedia.org/wiki/Oklahoma
2. Hit ctrl-F and type "explorers" (without the quotes).  Note that the page
correctly jumps to the word "explorers" in the article.
3. At the top of the page, click "edit this page".
4. Hit ctrl-F and type "explorers" (without the quotes).  

Actual Results:  
The page does not jump to the word "explorers", and "Phrase not found" has
appeared in the search bar.  However, by scrolling through the text, you can see
that "explorers" does exist in the editable text field.

Expected Results:  
Scrolled the page so that the edit field is visible, and scrolled the edit field
so that the word being searched for is visible and highlighted.

Subsequent searches ("Find Next") should scroll to different edit fields, and
scroll the edit fields themselves, as appropriate.


This problem makes it much harder to edit Wikipedia articles than was true with
Firefox 0.9.1, which just used a Find dialog box.

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 252371 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.