Crash After Clicking on Mailto: Link in Gmail

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
15 years ago
12 years ago

People

(Reporter: inboxbillg, Assigned: blizzard)

Tracking

1.7 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040922 Firefox/0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040922 Firefox/0.10

Clicking on a mailto link contained in mail displayed by Gmail causes Firefox to
close and disappear from the display, leaving no processes behind.

Reproducible here about 3 times out of 4.

Reproducible: Sometimes
Steps to Reproduce:
1.
2.
3.




Have also seen versions of Mozilla shipping with SuSE 9.1, from the 1.6 series,
vanish similarly when trying to logon to Gmail.
Can you post a Talkback id (launch components/talkback/talkback to get the
Talkback id after you have sent the report)? 

Comment 2

15 years ago
I duplicated this using version 0.9.3 and got the following dump after the
process crashed:

(Gecko:3409): GLib-GObject-CRITICAL **: file gvaluetypes.c: line 588
(g_value_set_boolean): assertion `G_VALUE_HOLDS_BOOLEAN (value)' failed
/firefox/run-mozilla.sh: line 451:  3409 Segmentation fault      "$prog" ${1+"$@"}
[1]   Exit 139

Comment 3

14 years ago
confirming with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv: 1.7.6)
Gecko/20050225 Firefox/1.0.1.

I should also add that firefox also crashes when running it and going straight
to gmail.
i.e. Running firefox and entering gmail.com crashes the browser, while opening a
new tab before going to gmail doesn't.

probably javascript related?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

14 years ago
Assignee: firefox → blizzard
Component: General → Widget: Gtk
Product: Firefox → Core
QA Contact: general → ian
Version: unspecified → 1.7 Branch

Comment 4

14 years ago
This seems to be not linux only bug. I experienced same problem with the 
latest trunk version of firefox on Windows XP (talkback ID = TB9801542K ).

Also, I had a chance to break at the point where the crash happend with my 
debug build.

In js/src/jsscript.c,

void
js_MarkScript(JSContext *cx, JSScript *script, void *arg)
{
    JSAtomMap *map;
    uintN i, length;
    JSAtom **vector;

    map = &script->atomMap;
>> The parameter 'script' was passed as null and crash happened here....

Here are several lines from call stack. And please let me know if someone 
wants to have more information from debugging session. I'll try reproduce it.

js3250.dll!js_MarkScript(JSContext * cx=0x04765ad0, JSScript * 
script=0x00000000, void * arg=0x00000000)  Line 1342 + 0x3
js3250.dll!fun_mark(JSContext * cx=0x04765ad0, JSObject * obj=0x04b20168, void 
* arg=0x00000000)  Line 1357 + 0x14
js3250.dll!js_Mark(JSContext * cx=0x04765ad0, JSObject * obj=0x04b20168, void 
* arg=0x00000000)  Line 4119 + 0x12
js3250.dll!MarkGCThing(JSContext * cx=0x04765ad0, void * thing=0x04b20168, 
unsigned char * flagp=0x04b1e795)  Line 1146 + 0x23
js3250.dll!js_MarkGCThing(JSContext * cx=0x04765ad0, void * thing=0x04b20168, 
void * arg=0x00000000)  Line 1446 + 0x11

Comment 5

14 years ago
daj2@cs.wustl.edu / jeongkyu.kim@gmail.com: one of your bugs is different. i 
had reassigned based on daj2@cs.wustl.edu's comment.

Comment 6

14 years ago
(In reply to comment #5)
> daj2@cs.wustl.edu / jeongkyu.kim@gmail.com: one of your bugs is different. i 
> had reassigned based on daj2@cs.wustl.edu's comment.

Hi timeless,

Then would it be better to file another bug for my case?

Comment 7

14 years ago
please, also copy the talkback report starting with "Incident ID:" to the end. 
product: Core, component: JavaScript Engine.

Comment 8

14 years ago
(In reply to comment #7)
> please, also copy the talkback report starting with "Incident ID:" to the end. 
> product: Core, component: JavaScript Engine.

Thanks for the explanation.
I filed a nwe bug for my case, bug 310493.
Does this occur in a recent trunk build?
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
-> WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.