Automatically attempt using alternate SMTP servers when the default fails

VERIFIED DUPLICATE of bug 167506

Status

MailNews Core
Networking: SMTP
--
enhancement
VERIFIED DUPLICATE of bug 167506
13 years ago
9 years ago

People

(Reporter: Mark Derricutt, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

I currently have two SMTP servers configured in thunderbird, one for my wireless
ISP I use at home, and one for the internal office mail server.

After having used the laptop at home with the wireless ISP server set as default
I return to the office, where I connect to the LAN, where mail fails through the
ISP server ( relaying ), and I have to manually open the advanced SMTP server
settings dialog and change my default SMTP server to that of works.

The same process occurs when I return home and are connected via my ISP again.

What would be good is that if the current default server fails, prompt the user
to try the next configured SMTP server, and if that works, make that the default
*for this session*.


Reproducible: Always
Steps to Reproduce:
1. Configure one SMTP server
2. Switch to a different LAN that will fail relay rules
3. Send message

Actual Results:  
Send failure.

Expected Results:  
As proposed, the user should be prompted to try the next, or another server ( if
more than 1 other server is configured ), and message automatically resent.

Updated

13 years ago
Severity: minor → enhancement
Component: General → Networking: SMTP
OS: Windows XP → All
Product: Thunderbird → MailNews
Hardware: PC → All
Summary: When multiple SMTP servers are configured and the default fails, cycle to use others → Automatically attempt using alternate SMTP servers when the default fails
Version: unspecified → Trunk
Product: MailNews → Core

Comment 1

13 years ago
*** Bug 285388 has been marked as a duplicate of this bug. ***

Comment 2

13 years ago
*** Bug 287379 has been marked as a duplicate of this bug. ***

Comment 3

13 years ago
*** Bug 295260 has been marked as a duplicate of this bug. ***
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 5

12 years ago

*** This bug has been marked as a duplicate of 167506 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
Status: RESOLVED → VERIFIED
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.