If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add a "Clear" button to the Bookmark Manager's Search field in Mozilla.

RESOLVED FIXED

Status

SeaMonkey
Bookmarks & History
--
enhancement
RESOLVED FIXED
13 years ago
8 years ago

People

(Reporter: Rolf Sponsel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.7.2) Gecko/20040803
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.7.2) Gecko/20040803

Add a "Clear" button to the Bookmark Manager's Search field/panel, to be
consistent with the 'View' panel of Mozilla Mail, and to allow for easy
clearing/resetting of the search by ONE click (instead of select and delete, or
click and backspace repeated).

The absense of this feature is quite annoying.


Reproducible: Always
Steps to Reproduce:
1. Display Bookmark Manager
2. Perform a search via the Search field by entering some chars
3. Now try to clear the Search field in ONE operation.

Actual Results:  
I cannot clear the Search field in one operation.

Expected Results:  
A button named 'Clear' appended to the right end of the Search field.
Product: Browser → Seamonkey

Comment 1

13 years ago
"The absense of this feature is quite annoying." especially since, from a
usability point of view, the user's hand is almost certainly on the mouse
(they've most likely just selected a bookmark) and not th keyboard.
Assignee: p_ch → nobody
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: nobody → nobody

Comment 2

8 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 3

8 years ago
*** This bug has been confirmed by popular vote. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

8 years ago
SeaMonkey 2.0.x now has this feature implemented by the "looking glass", found at the right end of the "Search Bookmarks" text entry field, changing into a "cross" whenever one enters some text in the box. The field can now be cleared by clicking on that cross.

I consider this feature request hereby implemented and this bug should be marked RESOLVED and FIXED
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.