Drop-down doesn´t work, clicking on "GO" button has no effect

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: Fernando Cassia, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040804 Netscape/7.2 (ax)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040804

In IE, under the section "support" you are able to select any country from the
drop-down menu, click on "GO" and the browser proceeds.

Under Mozilla, the drop-down has no effect, and clicking on the "GO" button has
no effect. From a simple inspection, that web page relies heavily on javascript.

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.rad.com/Home/0,6583,574,00.html
2. Select any country from the drop-down menu
3. attempt to click on "GO" button

Actual Results:  
Nothing happens

Expected Results:  
Jumped to selcted url.
WFM

But that page seems to have lot of ie targeted javascript code like event. I
think that page should be added to evangelism list so they begin to use DOM
compliant js.

Comment 2

14 years ago
WFM - rv:1.8a3 Gecko/20040817
but document.all is used and many more javascript errors

Comment 3

14 years ago
WORKSFORME
Mozilla 1.8a4 build 2004092404 under XP Pro SP2 here.

Hundreds of js errors being reported because of IE specific code:

Warning: Non-standard document.all property was used. Use W3C standard
document.getElementById() instead.
Source File:
http://www.rad.com/Cmm/Hpage/CmmAppHomePageHTMLJavaScriptFunctionsJS/0,11884,,00.js?CatPath=/RAD/Home&CatID=703
Line: 117

Warning: Element referenced by ID/NAME in the global scope. Use W3C standard
document.getElementById() instead.
Source File:
http://www.rad.com/Cmm/Hpage/CmmAppHomePageHTMLJavaScriptFunctionsJS/0,11884,,00.js?CatPath=/RAD/Home&CatID=703
Line: 120

Error: event is not defined
Source File:
http://www.rad.com/Cmm/Hpage/CmmAppHomePageHTMLJavaScriptFunctionsJS/0,11884,,00.js?CatPath=/RAD/Home&CatID=574
Line: 145

and hundreds of reported CSS parsing errors in javascript console too.


> that page should be added to evangelism list so they begin to use DOM
compliant js.
Maybe this is being done at bug 206847

I'm resolving this as WORKSFORME but I'll add a few words in bug 206847.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.