completion of address doesn't remove proposed part

RESOLVED DUPLICATE of bug 261272

Status

MailNews Core
Composition
RESOLVED DUPLICATE of bug 261272
13 years ago
9 years ago

People

(Reporter: Leos Literak, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; cs-CZ; rv:1.7) Gecko/20040616
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; cs-CZ; rv:1.7) Gecko/20040616

While typing email address (to, cc etc), mozilla offers me list of known
addresses. I select some, which is correctly added to the line. Unfortunatelly
sometimes the address line is not reset before this, so it contains part of
typed text, two separator chars and address.

E.g.

sy >> Zdenka Sykorova
I expect:
Zdenka Sykorova
only

I will attach screenshot

Reproducible: Sometimes
Steps to Reproduce:
1. type few characters of recepient
2. select one recepient of proposed addresses
3. press enter to confirm

Actual Results:  
address line is filled, but it contains characters I entered manually plus >>


Expected Results:  
only selected email address (or name, if she is in address book)
(Reporter)

Comment 1

13 years ago
Created attachment 159954 [details]
screenshot

I typed "sy", selected from list and pressed enter. Her nickname is "sykorka",
that's why she was matched by "sy" prefix.

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 261272 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.