Closed Bug 261394 Opened 17 years ago Closed 17 years ago

find toolbar highlight blocks input field

Categories

(Toolkit :: Find Toolbar, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 256989

People

(Reporter: emilian.bold, Assigned: bugzilla)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10

The find toolbar highlight option also highlights the text in the Google
inputbox. This basically stops you from changing the highlighted text in the
inputbox. I've noticed that if the keyword is "testxy" and the search string has
"testxy" as the last string than there is nothing you can do but close the tab
or use "delete" key. If "testxy" is not the last word then you can delete the
"testxy" highlighted string but not edit it or move the cursor through it.

Reproducible: Always
Steps to Reproduce:
1.Open a new tab.
2.Open Find tab. Type "testxy"
3.Go to google bar Ctrl+K. Type "search testxy" then enter.


Actual Results:  
Now, the input textbox for the search string should have "testxy" highlighted.

Expected Results:  
The search string shouldn't be highlighted in the input box, or the highlighted
text should allow the cursor move.
(In reply to comment #1)
> dupe if bug 250414 ?
> see https://bugzilla.mozilla.org/show_bug.cgi?id=250414#c7
> 

Yes, so it seems. But not only the text cannot be partially selected but you
can't move the text cursor "into" it either.

*** This bug has been marked as a duplicate of 256989 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.