palm sync does not change TB address book even if log and return codes indicate successful sync

RESOLVED INVALID

Status

MailNews Core Graveyard
Palm Sync
--
major
RESOLVED INVALID
14 years ago
9 years ago

People

(Reporter: Nik the Greek, Assigned: Bienvenu)

Tracking

1.0 Branch
x86
Windows XP

Details

(Whiteboard: workaround set HSM to desktop overrides handheld)

Attachments

(4 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

The Palm sync extension, once installed, adds Mozilla Address Book conduit to
the synchronization list - but when syncing the 'Mozilla Address Book' conduit
appears for a fraction of a second and no changes are made to Thunderbird's
address book.
I tired setting the conduit to 'sync'/'handheld overrides' but it makes no
difference.
The synchronization with Palm Desktop works ok.


Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
I also have the same problem.  I am running TB 1.0.

Comment 2

14 years ago
Me too with Windows XP and TB 1.0

Comment 3

13 years ago
Is this a problem using current version of TB, and you don't get any error
message of any kind, unlike bug 234391   (note: someone found bug 214407 to be
helpful)

version  1.0.5 available at
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/1.0.5/

Comment 4

13 years ago
I've seen this. It most commonly occurs when changing "use secure connection (ssl)" option. It generates a second secure or not secure address book.

TB 1.5 (20051114)

Comment 5

13 years ago
Henry, Geof - does comment 4 apply in your case?


(In reply to comment #4)
> I've seen this. It most commonly occurs when changing "use secure connection
> (ssl)" option. 

"use secure connection" where? - imap, ldap, ...


>It generates a second secure or not secure address book.

Please explain in more detail.
 

Comment 6

13 years ago
I don't know what comment #4 is refering to...  I don't think there is a "secure connection" option for address book synchronization.  I have never used IMAP with TB.

(In reply to comment #5)
> Henry, Geof - does comment 4 apply in your case?
> 
> (In reply to comment #4)
> > I've seen this. It most commonly occurs when changing "use secure connection
> > (ssl)" option. 
> 
> "use secure connection" where? - imap, ldap, ...
> 
> >It generates a second secure or not secure address book.
> 
> Please explain in more detail.
> 
> 

Comment 7

13 years ago
(In reply to comment #5)
> Henry, Geof - does comment 4 apply in your case?
> 
> 
> (In reply to comment #4)
> > I've seen this. It most commonly occurs when changing "use secure connection
> > (ssl)" option. 
> 
> "use secure connection" where? - imap, ldap, ...
> 
> 
> >It generates a second secure or not secure address book.
> 
> Please explain in more detail.
> 
> 

Sorry, was navigating through some bugs and somehow posted the comment into this bug. I was aiming for https://bugzilla.mozilla.org/show_bug.cgi?id=313073, which would make more sense.

Comment 8

13 years ago
Please consult http://kb.mozillazine.org/PalmSync_%28Thunderbird%29, bug 261405 and the Thunderbird forum at http://forums.mozillazine.org/viewforum.php?f=28 - then please report back your results (I hope it will be good news).

If no response in 2 weeks I'll assume it's working for you and will close the bug. (Sorry it's been so long since last contact)
Component: Address Book → MailNews: Palm Sync
Product: Thunderbird → Core
Version: unspecified → 1.0 Branch

Updated

13 years ago
Assignee: mscott → bienvenu
QA Contact: vseerror

Comment 9

13 years ago
Several folk in my office continue to have the same problem.  We've followed all the prescribed solutions with no success.  Hotsync says its doing the work and seems to spend an appropriate amount of time on it but we can't see any effect in either the Palm or the Thunderbird address books.

I'd be happy to supply any documentation you need.  Let me know.

Geoff

Comment 10

13 years ago
1. Go to: Control Panel > System > Advanced > Environmental Variables
2. setup the variable MOZ_CONDUIT_LOG with a value of C:\mozconduitlog.txt
3. c:\mozconduitlog.txt will log your hotsync progress
4. please add contents of mozconduitlog.txt as comment to this bug 
Severity: normal → major

Comment 11

13 years ago
Created attachment 207980 [details]
Geoff's comment of 1/1/06

Comment 12

13 years ago
Created attachment 208387 [details]
Hotsync log while not changing address book entries

Comment 13

13 years ago
Same problem here.  I have Win2K, Thunderbird v1.5 (20051201) and Firefox 1.5. Palm Hotsync w/ regular Desktop conduits works fine.

1. I have installed Contacts Sidebar 0.6, Palmsync.xpi. 

2. I have changed the conduits ('Do Nothing' for Contacts and 'Synchronise' or 'Handheld overwrites Desktop' for Mozilla Address Book).

Here's what happens:

i. Each time I sync, a new category is added to the Mozilla address book from the Palm; however, it has no entries.   

ii. I did this 14 times and each time a new category was added, again with no entries.  Palm data seemed unaffected.

iii. I took the precaution of creating the conduit.log as described elsewhere and it has some rather interesting entries.  It logged all of the hotsyncs above in (ii).  I have attached it here.  I could speculate here - the category indices are not in sequence, I have 16 categories in the Moz address book (14 in Palm) and so on - but I don't really know what it means.

It spends about 25 seconds on the Mozilla Address Book each time, and now that all the categories are there, seems to do nothing.

Any ideas?

Thanks very much in advance.

Justin

Comment 14

13 years ago
Here's my most recent Hotsync log which is set to 'Synchonise' instead of 'Handheld overwrites Desktop' as with the previous ones in the posted log.  Still nothing in the Address books, except the Personal Address Book which collects the addresses from Tbird emails and does *not* exist on the Palm.  

Forgot to mention: I have Hotsync v 6.0.1 and Desktop Palm 4.1.4 if that's relevant.

Thanks, Justin

------------ START OF PALM SYNC ------------ at Fri Jan 13 17:02:05 2006
Getting moz AB List ... Done getting moz AB List. 
first device = 0
Moz AB[0] category index/synced=-1/0, name= 'Personal Address Book', url= 'moz-abmdbdirectory://abook.mab'
Moz AB[1] category index/synced=-1/0, name= 'Collected Addresses', url= 'moz-abmdbdirectory://history.mab'
Moz AB[2] category index/synced=-1/0, name= 'Unfiled', url= 'moz-abmdbdirectory://abook-1.mab'
Moz AB[3] category index/synced=-1/0, name= 'Business', url= 'moz-abmdbdirectory://abook-2.mab'
Moz AB[4] category index/synced=-1/0, name= 'Personal FG', url= 'moz-abmdbdirectory://abook-3.mab'
Moz AB[5] category index/synced=-1/0, name= 'LBS', url= 'moz-abmdbdirectory://abook-6.mab'
Moz AB[6] category index/synced=-1/0, name= 'Personal BG', url= 'moz-abmdbdirectory://abook-4.mab'
Moz AB[7] category index/synced=-1/0, name= 'Clubs & Grub', url= 'moz-abmdbdirectory://abook-5.mab'
Moz AB[8] category index/synced=-1/0, name= 'Useful', url= 'moz-abmdbdirectory://abook-7.mab'
Moz AB[9] category index/synced=-1/0, name= 'Family-Winter', url= 'moz-abmdbdirectory://abook-8.mab'
Moz AB[10] category index/synced=-1/0, name= 'HH', url= 'moz-abmdbdirectory://abook-9.mab'
Moz AB[11] category index/synced=-1/0, name= 'Investors', url= 'moz-abmdbdirectory://abook-10.mab'
Moz AB[12] category index/synced=-1/0, name= 'FT96 02-04-02', url= 'moz-abmdbdirectory://abook-11.mab'
Moz AB[13] category index/synced=-1/0, name= 'Suppliers', url= 'moz-abmdbdirectory://abook-12.mab'
Moz AB[14] category index/synced=-1/0, name= 'Business Plus', url= 'moz-abmdbdirectory://abook-13.mab'
Moz AB[15] category index/synced=-1/0, name= 'Family-Mencher', url= 'moz-abmdbdirectory://abook-14.mab'

Processing Palm AB 'Unfiled' (catIndex/catId) = (0/0)... 
Category index = 0, name = 'Unfiled' has not been synced before
  Syncing with moz AB with 60 modified Palm record(s) ... Done syncing AB. retval=80004005.

Processing Palm AB 'Business' (catIndex/catId) = (1/1)... 
Category index = 1, name = 'Business' has not been synced before
  Syncing with moz AB with 616 modified Palm record(s) ... Done syncing AB. retval=80004005.

Processing Palm AB 'Personal FG' (catIndex/catId) = (2/2)... 
Category index = 2, name = 'Personal FG' has not been synced before
  Syncing with moz AB with 73 modified Palm record(s) ... Done syncing AB. retval=80004005.

Processing Palm AB 'LBS' (catIndex/catId) = (5/128)... 
Category index = 128, name = 'LBS' has not been synced before
  Syncing with moz AB with 173 modified Palm record(s) ... Done syncing AB. retval=80004005.

Processing Palm AB 'Personal BG' (catIndex/catId) = (6/129)... 
Category index = 129, name = 'Personal BG' has not been synced before
  Syncing with moz AB with 172 modified Palm record(s) ... Done syncing AB. retval=80004005.

Processing Palm AB 'Clubs & Grub' (catIndex/catId) = (7/130)... 
Category index = 130, name = 'Clubs & Grub' has not been synced before
  Syncing with moz AB with 22 modified Palm record(s) ... Done syncing AB. retval=80004005.

Processing Palm AB 'Useful' (catIndex/catId) = (8/131)... 
Category index = 131, name = 'Useful' has not been synced before
  Syncing with moz AB with 90 modified Palm record(s) ... Done syncing AB. retval=80004005.

Processing Palm AB 'Family-Winter' (catIndex/catId) = (9/141)... 
Category index = 141, name = 'Family-Winter' has not been synced before
  Syncing with moz AB with 22 modified Palm record(s) ... Done syncing AB. retval=80004005.

Processing Palm AB 'HH' (catIndex/catId) = (10/134)... 
Category index = 134, name = 'HH' has not been synced before
  Syncing with moz AB with 42 modified Palm record(s) ... Done syncing AB. retval=80004005.

Processing Palm AB 'Investors' (catIndex/catId) = (11/144)... 
Category index = 144, name = 'Investors' has not been synced before
  Syncing with moz AB with 19 modified Palm record(s) ... Done syncing AB. retval=80004005.

Processing Palm AB 'FT96 02-04-02' (catIndex/catId) = (12/136)... 
Category index = 136, name = 'FT96 02-04-02' has not been synced before
  Syncing with moz AB with 125 modified Palm record(s) ... Done syncing AB. retval=80004005.

Processing Palm AB 'Suppliers' (catIndex/catId) = (13/16)... 
Category index = 16, name = 'Suppliers' has not been synced before
  Syncing with moz AB with 4 modified Palm record(s) ... Done syncing AB. retval=80004005.

Processing Palm AB 'Business Plus' (catIndex/catId) = (14/137)... 
Category index = 137, name = 'Business Plus' has not been synced before
  Syncing with moz AB with 38 modified Palm record(s) ... Done syncing AB. retval=80004005.

Processing Palm AB 'Family-Mencher' (catIndex/catId) = (15/142)... 
Category index = 142, name = 'Family-Mencher' has not been synced before
  Syncing with moz AB with 21 modified Palm record(s) ... Done syncing AB. retval=80004005.

Moz AB[0] category index = -1, name = 'Personal Address Book' doesn't exist on Palm so needs to be added to palm
  Loading moz AB records failed so can't create new Palm AB. retval=-2147467259.

Moz AB[1] category index = -1, name = 'Collected Addresses' doesn't exist on Palm so needs to be added to palm
  Loading moz AB records failed so can't create new Palm AB. retval=-2147467259.
------------ END OF PALM SYNC ------------ at Fri Jan 13 17:02:18 2006

Comment 15

13 years ago
Justin and ALL users of Thunderbird 1.5 

Please try the updated palmsync for thunderbird 1.5 (on http://kb.mozillazine.org/PalmSync_%28Thunderbird%29 ) and report back
so we know that you are good. If not working then please supply build string and hotsync log per comment  10 when reporting back -- thanks  (justin you missed getting the new xpi by a few hours)

Note
1. the updated palmsync for 1.5 eliminates the need for contacts sidebar.
2. the updated palmsync for 1.5 AFAIK is NOT for TB 1.0

Users of contacts sidebar - CS 0.5 is for TB 1.0, CS 0.6 is for TB 1.5 - per http://jpeters.no-ip.com/extensions/?page=tb_cs

Comment 16

13 years ago
Damn!  That sure is fine.  I can see my address book is in a good need of a clean up now, but everything seems to be working very well with Hotsync.

Thanks a million for working this out and for all the time you must have put into it.  It's really making Tbird so much more useful than just a standalone. Now for the Calendar...!

Best wishes,

Justin

Comment 17

13 years ago
(In reply to comment #16)
> Damn!  That sure is fine.  ...

> into it.  It's really making Tbird so much more useful than just a standalone.
> Now for the Calendar...!
...


Is there a corresponding bug for the calendar part of this? Thanks.

Comment 18

13 years ago
Justin  Is there a corresponding bug for the calendar part of this?   [repeat]

Comment 19

13 years ago
Sorry for the delay in replying and if my previous comment sign-off falsely raised your hopes about a Calendar for FF.  I was referring to Mozilla Calendar, which while it looks extremely promising, does not offer any sync facilities I'm aware of.  I used version 0.3a (though I've just noticed there's a new one up on 21-Jan-06).  So that's not an option for me right now.  No point in doing everything by hand - nicer to use a pen & paper if I'm going to do that.

Update on the Address Book Sync:  Unfortunately, although I had hoped to use the Mozilla Address Book to get easy access to my up-to-date email addresses, I have found a couple of serious problems and have given up on it for now.  Here are the problems: 

1. Some records do not appear in the MAB, even after repeated syncing.  Strangely, they still show up on the Palm.  The records in question do not seem to have any weird characters in them and I can see no other reasons for being singled out.

2. I also found the functionality of the MAB extremely limited in practice. You must have an address book for each category and you can't choose not to sync an address book.  This means that you can't create a mailing list without duplicating the records (and the subsequent updating & syncing overhead) which defeats the whole purpose...

3. You *must* keep an addressbook & category called 'Personal' on your Palm.  It's the default I guess, but that means that you've got to copy whatever is Personal into that category and then delete the old copies.  And, since I don't know if the Address book actually 'sees' ALL of my addresses, I can't reliably know if I'm copying everything, or losing data.

So bad news all round from me, I'm afraid - not using Address Book or Calendar yet. Because of this inconsistency, I've gone back to the Palm Desktop for the time being.

Apologies if I've missed any health warnings on this code - no criticism meant if it's not for prime time yet.  Just doesn't serve my needs at the mo.

HTH.
(Assignee)

Comment 20

13 years ago
Justin, there is a way to choose not to sync a particular address book, though there is no UI for it. Just set the following pref using tools | options | advanced | config editor

pref("ldap_2.servers.<ab name>.disablePalmSync", true);

that's probably not sufficient to work around the issues you're having, but it might be a start.

Comment 21

13 years ago
Seems to be working for me now - thanks so much.  Been waiting a long time for this.

Comment 22

13 years ago
(In reply to comment #21)
> Seems to be working for me now - thanks so much.  Been waiting a long time for
> this.

Geoff is your office still 1.0? Or are you now 1.5?

Comment 23

13 years ago
I tested using 1.5

Comment 24

12 years ago
(In reply to comment #20)
> Justin, there is a way to choose not to sync a particular address book, though
> there is no UI for it. Just set the following pref using tools | options |
> advanced | config editor
> 
> pref("ldap_2.servers.<ab name>.disablePalmSync", true);

disablePalmSync is courtesy of Bug 227507

Comment 25

12 years ago
Henry - what is your status?
Nick - what is your status?

Geoff is OK - comment 21
Justin was still having trouble - comment 19

Justin I think any major issues you have will be more effectively addressed in new bug(s). Some comments below.

(In reply to comment #19)
>... 
> 1. Some records do not appear in the MAB, even after repeated syncing. 
> Strangely, they still show up on the Palm.  The records in question do not seem
> to have any weird characters in them and I can see no other reasons for being
> singled out.

Need a new bug with minimal testcase - an address book (attached to the bug or e-mailed) that had only the "bad" addresses and a conduit log. Please exclude all the other address books with the exclusion pref David mentioned. 


> 2. ... You
> must have an address book for each category and you can't choose not to sync an
> address book.  This means that you can't create a mailing list without
> duplicating the records (and the subsequent updating & syncing overhead) which
> defeats the whole purpose...

known bugs - TB AB does not presently have a concept of categories, plus palmsync does not support mailing lists.

 
> 3. You *must* keep an addressbook & category called 'Personal' on your Palm. 
> It's the default I guess, but that means that you've got to copy whatever is
> Personal into that category and then delete the old copies.  And, since I don't
> know if the Address book actually 'sees' ALL of my addresses, I can't reliably
> know if I'm copying everything, or losing data.

I don't quite understand where you are coming from - why must you copy everything to "personal"?

Question - are you starting with all of your data in the palm, or in Thunderbird?


If there's no news from Henry or Nick this bug will be closed.

Comment 26

12 years ago
Created attachment 250340 [details]
mozconduitlog.txt

The problem has returned for me.  I'm using Windows XP latest version, TB 1.5 and the latest versions of Hotsync and Palm software for Treo 650.  I rebuilt everything by removing the Palm Desktop with the Windows remove software function and then added everything back again and it still does not sync.  Attached are the and the sync log and the build string.

I notice that the version of the sync conduit in Palmsync.xpi for TB 1.0 is 0.6.0.0 whereas its 0.4.0.0 for the TB1.5 version - that seems weird!  Also, there seem to be different versions of palmsync.xpi around on the site.  As you can see from the install log, one of them has an extra step that deletes compreg.dat in the profile.

Is there a component on the Palm that might be missing that we should check?  It seems from the mozconduit.log that hotsync is asking a question that isn't getting answered by the Palm.

Comment 27

12 years ago
Created attachment 250341 [details]
palmsync.xpi install log

Comment 28

12 years ago
And now its working.  I don't know why!%@$!#@.  I think all I did was set Desktop to overwrite handheld then the sync worked.  Then I set back to sync the files and its still working.

Comment 29

12 years ago
(In reply to comment #28)
> And now its working.  I don't know why!%@$!#@.  I think all I did was set
> Desktop to overwrite handheld then the sync worked.  Then I set back to sync
> the files and its still working.
> 

Congratulations!

If setting the Desktop to overwrite the handheld fixed your problem then your problem almost certainly resulted from data corruption on your handheld Palm unit. The odds are therefore very high that there was nothing wrong with TBird or PalmSync.

What you have seen here is a common Palm handheld data corruption issue regardless of whether you are syncing with TBird via PalmSync, the Palm Desktop or any other 3rd party conduit and the solution is always to overwrite the handheld with Desktop data. 

FYI,

Gordon

Comment 30

11 years ago
If we accept Gordon's experience that a solution is essentially not possible by changing palmsync, the this bug will be closed invalid.  

Before going that route, do we know if there was a time in palmsync's life, going back to the very earliest days, when this type of thing didn't happen?  In other words the possibility that this might be a regression?

noting in whiteboard the workaround is to set HSM to "desktop overrides handheld."
Summary: palm sync does not change address book → palm sync does not change address book even if log and return codes indicate successfully completed sync process
Whiteboard: workaround set HSM to desktop overrides handheld

Comment 31

10 years ago
=> INVALID  in follow up to comment 30 (which got no new responses from reporters)

If workaround - set HSM to "desktop overrides HSM handheld" for one HS run and then change back to HS set to synchronize - doesn't resolve the problem and you still see a problem:
- reference http://kb.mozillazine.org/PalmSync_-_Thunderbird
- please file a new bug 

Thanks Geoff and others for your help.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID
Summary: palm sync does not change address book even if log and return codes indicate successfully completed sync process → palm sync does not change TB address book even if log and return codes indicate successful sync
Product: Core → MailNews Core

Comment 32

9 years ago
*** This bug has been confirmed by popular vote. ***
Component: Palm Sync → Palm Sync
Ever confirmed: true
Product: MailNews Core → MailNews Core Graveyard
You need to log in before you can comment on or make changes to this bug.