Key bindings no longer work and no option to change them

VERIFIED DUPLICATE of bug 260572

Status

()

defect
VERIFIED DUPLICATE of bug 260572
15 years ago
13 years ago

People

(Reporter: Michael-Reilly, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Firefox 1.0PR

The emacs binding no longer work and there does not appear to be a way to make
them work without editing platformHTMLBindings.xml.

Up to and including 0.9.3 the key bindings worked properly on Linux.  It looks
like a decision was made in 1.0PR to compell everyone to adopt the Microsoft
Windows key bindings regardless of the platform they are using.

Reproducible: Always
Steps to Reproduce:
1.Hit ^A in the address/URL field
2.
3.
Actual Results:  
^A - the while line is highlighted

Expected Results:  
Moved the ciursor to the beginning of the line

Why the desire to force the Windows keyboard interface onto everyone?
Why the desire to make it difficult to fix this via user prefs?

This behavior makes firefox 1.0PR a non-starter for many of us.  We are staying
with 0.9.3 for now.
we're now using the GNOME keybinding settings.  If you set it to use the emacs
keybindings, we'll use them too.

add 
gtk-key-theme-name = "Emacs"
to
~/.gtkrc-2.0
and you should be good to go.

*** This bug has been marked as a duplicate of 260572 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

15 years ago
Thank you for the information.  However I do not use gnome and have no desire to
do so.  How do I get the behavior I had in 0.9.3 back?
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

15 years ago
The instructions in comment 1 should work even if you don't use Gnome.

*** This bug has been marked as a duplicate of 260572 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.