Closed Bug 261478 Opened 20 years ago Closed 19 years ago

Option to hide tabs and navigational toolbar in fullscreen mode

Categories

(Firefox :: Toolbars and Customization, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 126718

People

(Reporter: sskroeder, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; da-DK; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; da-DK; rv:1.7) Gecko/20040803 Firefox/0.9.3

When Firefox is in fullscreen mode, i would like to have an option to hide
navigational toolbar (and mabye even the Tab pane)...  

Not to compare too much with IE - but in IE 6.0 one has the option to make the
Fullscreen toolbar disappear (in that mode, it slides away after a second or so,
and does not reappear unless you move the mouse to the top of the screen)

When the navigational toolbar (and the tab pane) is gone - and you're left with
the content of the web-page on the screen, (what i would call True Fullscreen)
the door is open for making presentations and such via the Firefox browser ;-)
-- also this would be a nice feature, if one was to develop a "Kiosk-mode"
version of Firefox...

to see what it would look like - do the following :
  1) enable the option to hide the tab pane, when only one tab is open
  2) disable the navigation toolbar
  3) go to any web page with some content ;-)
  4) press F11

Now - the reason for this request for enhancement (for something which seemingly
is possible already) is that this is only possible if :
  1) only one tab is in use
  2) the 'hide tab pane when only one tab' is enabled
  3) one manually disables the navigation toolbar

Meanning, that when you leave yor fullscreen mode - you have to enable the
navigation toolbar again, you can't have True Fullscreen it in a multi-tab
situation...

Reproducible: Always
Steps to Reproduce:
1. Enter fullscreen by pressing F11
Actual Results:  
The toolbar (navigation) is shown

Expected Results:  
If option to hide navigation toolbar enabled - hide this...
Try Toolbar Enhancements extension (aka tbx). It adds a context menu item in
when you click on a toolbar in customize mode.
Confirming -- this is possible using the AutoHide extension (i'm using 0.9.5
with Firefox 1.0PR) 
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
Assignee: bugs → nobody
QA Contact: bugzilla → toolbars
*** Bug 309297 has been marked as a duplicate of this bug. ***
Summary: When in fullscreen mode, navigational toolbar should be hidden → Option to hide tabs and navigational toolbar in fullscreen mode
Bug 199387, filed for the suit, is very similar.  Also see bug 126718 for
auto-hiding toolbars.
Thinking about it, bug 126718 pretty much covers this.

*** This bug has been marked as a duplicate of 126718 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.