CSS interpreter produces invalid borders and scaling

RESOLVED DUPLICATE of bug 261498

Status

()

Core
Embedding: APIs
--
major
RESOLVED DUPLICATE of bug 261498
13 years ago
13 years ago

People

(Reporter: Eric Esterle, Assigned: Adam Lock)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040924
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040924

This CSS bug viewable here:
http://cme.geneticsolutions.com/db/servlet/TopicReq?id=2152

Happens in Mozilla 1.7.3 running on Gentoo 2004.2 and Fedora Core 1 Linux with
"--enable-xft" configure option set.  With "--disble-xft" the CSS appears
correctly.  This used to happen on Windows 98/200/XP in browser version 1.6, but
was fixed in 1.7+, the bug still exists in Linux though. 

Reproducible: Always
Steps to Reproduce:
1. Make sure you use Mozilla 1.7.x with XFT fonts
2. Browse to http://cme.geneticsolutions.com/db/servlet/TopicReq?id=2152
3. Compare the rendered page to the same page opened without XFT fonts, or with
Mozilla 1.7+ on Windows.

Actual Results:  
The border images are not spaced correctly and some sections are not displayed
at all.

Expected Results:  
Rendered all borders consistently and fluint with no apparent sectional spacing.

-. Default theme used.
-. Browser didn't crash
-. Computers discovered on Dell Poweredge 400SC Intel P4 2.4 - 3 GHz, 
-. The CSS on this page was validated by w3c's CSS validator and the section
that displays the borders was validated successfully.

about:buildconfig
------------------
--enable-optimize=-O2 --enable-old-abi-compat-wrappers --disable-activex
--disable-activex-scripting --disable-installer --disable-pedantic
--enable-crypto --enable-mathml --enable-xterm-updates --with-pthreads
--with-system-jpeg --with-system-png --with-system-zlib --with-x
--without-system-nspr --disable-ipv6 --disable-ldap --disable-ldap-experimental
--enable-xinerama --enable-xprint --enable-gnomevfs
--enable-default-toolkit=gtk2 --disable-debug --disable-tests --enable-reorder
--enable-strip --enable-strip-libs --enable-elf-dynstr-gc --enable-xft
--enable-freetype2 --enable-freetypetest --disable-jsd --disable-xpctools
--enable-oji --disable-calendar --disable-svg
--enable-extensions=default,gnomevfs --prefix=/usr/lib/mozilla
--with-default-mozilla-five-home=/usr/lib/mozilla

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 261498 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.