If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[PP]Jan22: Hidden attribute of CSS not rendering correctly.

VERIFIED WORKSFORME

Status

Core Graveyard
GFX
P2
normal
VERIFIED WORKSFORME
19 years ago
9 years ago

People

(Reporter: Chris Petersen, Assigned: troy)

Tracking

Trunk
PowerPC
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Version: Viewer.app
Build: Friday Jan 22
Platform:Mac
Expected Result: Objects that have been assigned to be hidden by css should not
be displayed.
What I got: The objects are display as white opaque rectangles.
Steps to reproduce:
1) In Viewe.app, go to www.hotwired.com.
2) In the middle frame, notice that several white rectangles are displayed. They
overlap other content on the page.
3) These class objects are created in CSS and are using the visibility set to
hidden. See the example below:

.pu1odd { position: absolute; left: 327px; top: 18px; width: 120px; height:
144px; border: 1px none red; layer-background-color: #ccffcc; background-color:
#ccffcc; z-index: 5; visibility: hidden; padding-left: 3px; padding-right: 3px }
(Reporter)

Comment 1

19 years ago
This only happens on the Mac.

Updated

19 years ago
Assignee: michaelp → pierre

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 2

19 years ago
*** Bug 2385 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Summary: Hidden attribute of CSS not rendering correctly. → [PP] Hidden attribute of CSS not rendering correctly.

Comment 3

19 years ago
Adding [PP] tag

Updated

19 years ago
Summary: [PP] Hidden attribute of CSS not rendering correctly. → [PP]Jan22: Hidden attribute of CSS not rendering correctly.

Comment 4

19 years ago
Inserting Milestone info.

Comment 5

19 years ago
Setting all current Open/Normal to M4.

Comment 6

19 years ago
per leger, assigning QA contacts to all open bugs without QA contacts according
to list at http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser

Updated

19 years ago
QA Contact: 4110 → 4144
Target Milestone: M4 → M3

Comment 7

19 years ago
petersen, can you check this with latest build?
(Reporter)

Comment 8

19 years ago
Cannot reproduce problem in Apprunner (March 10th Mac Build). The page source has
changed and no longer contains these css objects.

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 9

19 years ago
Setting to Verified/Invalid due to change in page.

Updated

19 years ago
Status: VERIFIED → REOPENED

Updated

19 years ago
Resolution: INVALID → ---

Updated

19 years ago
Status: REOPENED → ASSIGNED

Comment 10

19 years ago
I think that this bug has been closed a bit lightly. The page may have changed
but it doesn't mean that the bug went away. You can either recreate the HTML code
that shows the problem or ask someone to do it but please don't close a bug for
that reason.

Comment 11

19 years ago
I just did a search on "visibility: hidden" and got tons of hits for pages that
use it...can we find an alternative page that way? Like see
http://www.umaine.edu; it's drawing with some wierd blocky things, but I'm not
sure it's the same thing as was initially reported.
*Disclaimer: this is not my normal area, so I may be way off....*

Updated

19 years ago
Target Milestone: M3 → M4

Comment 12

19 years ago
CSS2 is not fully supported for M3.  Moving to M4 milestone.

Updated

19 years ago
QA Contact: 4144 → 4110

Updated

19 years ago
Assignee: pierre → troy
Status: ASSIGNED → NEW
Target Milestone: M4 → M5

Comment 13

19 years ago
Pushed to M5.

I tested on Mac and Windows and they both display the same way the pages on
hotwired.com and umaine.edu (hotwired is correct, umaine is not).

Reassigning to troy since the problem on umaine.edu is cross-platform.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 14

19 years ago
The bug was reported against www.hotwired.com and that looks fine with the
latest build so I'm marking it WORKSFORME

If someone wants to open a _separate_ bug for umaine.edu then go ahead, but be
specific about what is wrong

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 15

19 years ago
Verifying bug WORKSFORME as a more specific test case is needed as stated in 4/7
comments.

Updated

11 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.