Number of selected messages in status bar

RESOLVED FIXED in Thunderbird 3

Status

Thunderbird
Mail Window Front End
--
enhancement
RESOLVED FIXED
14 years ago
10 years ago

People

(Reporter: Peto, Assigned: Matthias Bockelkamp)

Tracking

Trunk
Thunderbird 3
Bug Flags:
blocking-thunderbird2 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.81 KB, patch
Scott MacGregor
: review+
Scott MacGregor
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10
Build Identifier: Mozilla Thunderbird version 0.8 (20040913)

Let the TB display number of selected messages. It could be useful feature.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

13 years ago
Yes, please.  Needed.  :)  Should be simple to add.

Comment 2

13 years ago
confirming
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All

Comment 3

13 years ago
xref bug 67636 -- this feature was just added to the suite.
(Assignee)

Comment 4

13 years ago
Created attachment 188726 [details] [diff] [review]
Patch for TB
Assignee: mscott → mbockelkamp
Status: NEW → ASSIGNED
Attachment #188726 - Flags: superreview?(bienvenu)
Attachment #188726 - Flags: review?(neil.parkwaycc.co.uk)

Comment 5

13 years ago
I'm not sure I'm so keen on adding this....

Comment 6

13 years ago
Comment on attachment 188726 [details] [diff] [review]
Patch for TB

I'm not a tb peer.
Attachment #188726 - Flags: review?(neil.parkwaycc.co.uk)
(Assignee)

Updated

13 years ago
Attachment #188726 - Flags: superreview?(mscott)
Attachment #188726 - Flags: superreview?(bienvenu)
Attachment #188726 - Flags: review?(mscott)

Comment 7

13 years ago
(In reply to comment #5 Scott MacGregor)
> I'm not sure I'm so keen on adding this....

curious why not?

Comment 8

12 years ago
This is an absolutely needed function.

Maybe it would make sense to be able to customize the information in the status bar choosing one or many numbers among :

* number of selected messages
* number of unread messages
* number of junk messages
* number of total messages
* ...

Comment 9

12 years ago
has patch
Flags: blocking-thunderbird2?

Comment 10

11 years ago
we're passed the string freeze for tb2.
Flags: blocking-thunderbird2? → blocking-thunderbird2-
Target Milestone: --- → Thunderbird 3

Comment 11

11 years ago
Comment on attachment 188726 [details] [diff] [review]
Patch for TB

I changed my mind on this and think we should take it. Thanks for the patch Matthias!
Attachment #188726 - Flags: superreview?(mscott)
Attachment #188726 - Flags: superreview+
Attachment #188726 - Flags: review?(mscott)
Attachment #188726 - Flags: review+

Updated

11 years ago
Whiteboard: [checkin needed]

Comment 12

11 years ago
Checked in:
mozilla/mail/base/content/commandglue.js                          1.77
mozilla/mail/locales/en-US/chrome/messenger/messenger.properties  1.46

I'm not sure how did you get this patch generated, but it's rather hard to apply automatically. Please run |cvs diff -up8N| from mozilla/ to produce a patch. If speed is an issue, you can specify the directories to diff after the diff flags.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]
Version: unspecified → Trunk

Updated

11 years ago
Duplicate of this bug: 385450

Comment 14

10 years ago
Sorry but I have Thunderbird 2.0.0.14 and it doesn't seem to be included ?
Has this function to be enabled some way ?
You need to log in before you can comment on or make changes to this bug.