nested ENTITY declarations not supported?

RESOLVED DUPLICATE of bug 69799

Status

()

--
major
RESOLVED DUPLICATE of bug 69799
14 years ago
14 years ago

People

(Reporter: petrovicky, Assigned: hjtoi-bugzilla)

Tracking

1.7 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040917 Firefox/0.10 (MOOX M3)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040917 Firefox/0.10 (MOOX M3)

take a look at the URL above.
there's a "footer" entity declaration, telling the parser to look in an external
XML file.
this entity declaration however breaks the DOCTYPE declaration (take a look at
the XML source code, line 4 - the ']>' string has a different colour than the
rest of  DOCTYPE).

this works in IE 6.

(btw. the same problem occurs in XHTML, when you try to define your own tags or
attributes. the ']>' is then displayed before all content of the site, breaking
the design)

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Actual Results:  
external XML file is not loaded and thus not displayed as an entity.

Expected Results:  
load an external XML file and display the entity.
(Reporter)

Updated

14 years ago
Version: Trunk → 1.7 Branch

*** This bug has been marked as a duplicate of 69799 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.