images unnecessarilly zoomed out in pop-ups (bad size checking)

VERIFIED DUPLICATE of bug 224293

Status

()

Core
ImageLib
VERIFIED DUPLICATE of bug 224293
13 years ago
13 years ago

People

(Reporter: Jeremy M. Dolan, Assigned: Stuart Parmenter)

Tracking

Trunk
x86
Linux
Points:
---
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
Seen this on a few sites lately, with Firefox 0.10. Filing under ImageLib as
someone on IRC "thinks" zoom is a Seamonkey feature too.

Observable at: http://www.nytimes.com/nytstore/clothing/NSNYTBC.html

Click 'view larger image', notice image is slightly zoomed out in pop-up window.
Click to bring to 100%, and select image with mouse to see borders. Notice it
has plenty of room to fit in the pop-up without zoom.

Comment 1

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

I see similar behavior, but with some different details.

When the popup comes up, if I left-click on the image (with +zoom cursor), I see
barely any change.  Also, the cursor remains +zoom.  If I move the mouse pointer
out of the window and back in again, it becomes a -zoom cursor.  If I click a
second time, the image remains unchanged and the cursor remains -zoom"  Moving
the mouse out and back in the window changes the pointer to +zoom.

I see no scroll borders in any case.
(Reporter)

Comment 2

13 years ago
Yes, those are actually the very same "details" I see on Linux. (er, that sounds
snippy... only meaning to clarify).

Two comments: Yes, the +zoom/-zoom cursor doesn't update immediately, but I only
need to move it 1 pixel for it to change, not out of the window and back in.
Second, there is "barely any change" because, as you can see if you enlarge the
pop-up window, it is only scaled to 99%.

I highly suspect this another observable effort of Gecko's poor margin creation
when directly viewing images. (see also bug 136002). It seems likely that the
margins Gecko actually displays the image with differ from those it "thinks"
it's displaying the image with, making Gecko believe scaling is necessary. (or
s/Gecko/imglib/, or pr0nlib, or whatever the backend responsible for this is
called nowadays).
Depends on: 136002
(Reporter)

Comment 3

13 years ago
Nominating for 1.0. This is really, really poor (non IE parity) layout we're
doing on a pretty common web site "feature". I think someone should at least see
what a fix would involve--maybe it's just a px value adjustment.
Flags: blocking-aviary1.0?

Comment 4

13 years ago
mostly looking for finding and fixing of regressions at this point...  do you
know if this is a recent regression?   renominate if so..
Flags: blocking-aviary1.0? → blocking-aviary1.0-

*** This bug has been marked as a duplicate of 224293 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.