add support for exporting webpages to pdf in firefox

RESOLVED DUPLICATE of bug 162659

Status

()

Core
Disability Access APIs
--
enhancement
RESOLVED DUPLICATE of bug 162659
14 years ago
14 years ago

People

(Reporter: watzlaw wutz, Assigned: Blake Ross)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

Using Firefox there is sometimes the need for saving the current page-content.
Currently it is possible to export pages to html. This results in a html-file
and a directory with additional elements (images, etc.).

It would be useful to have the possibility to export web-pages directly to pdf.

Although it is possible to install a pdf-printer the vast majority of users
won't do this. The other problem is, that using a printer all links are lost:
the resulting document only contains text.

Using IE pdf-export can be done using Acrobat Standard/Professional Plugin. For
FX there is no such possibility.

The feature should be reachable under "Save page as..." and maybe via a button
(like in OpenOffice).

See http://forums.mozillazine.org/viewtopic.php?t=122213 for a discussion and
additonal arguments.



Reproducible: Always
Steps to Reproduce:

Comment 1

14 years ago
This is a duplicate of Bug 162659.

*** This bug has been marked as a duplicate of 162659 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Component: General → Accessibility APIs
Product: Firefox → Browser
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.