Closed Bug 261559 Opened 16 years ago Closed 15 years ago

Thunderbird should register *.eml file type association

Categories

(Thunderbird :: Installer, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: keith, Assigned: Bienvenu)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10

Thunderbird now sets itself as the default mail application, but it does not
register itself to open .EML files. Thunderbird should register itself to handle
.eml files.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
This is a good idea, but until TB can actually open a .EML from the command line 
(bug 242959), it won't do much good.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Depends on: 242959
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
Summary: Thunderbird should register *.eml file type association on Linux/Unix with Gnome → Thunderbird should register *.eml file type association
(In reply to comment #0)
I filled the same bug, a while ago. It was marked as a duplicate of Bug26201.
Take a look at the discussion.

*** This bug has been marked as a duplicate of 26201 ***
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Reopening.  This is a Thunderbird bug.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
*** Bug 268009 has been marked as a duplicate of this bug. ***
Just to beat a dead horse: Hopefully when this is corrected a user will be able
to do the following from an imap/pop email account. 1. Save an email (*.eml)
file that has an attachment (spreadsheet, etc) to the desktop/folder/directory.
2. Delete the message from the imap/pop account. 3. Close Thunderbird. 4.
Double-click on the eml file causing Thunderbird to launch so that the user can
read the email message and access the attachement.
Blocks: 269826
No longer depends on: 269826
Mscott, this is one of the most confusing bugs for new users.
New users will download and install Thunderbird, they will make Thunderbird as
their default mail application. Maybe they will save some mails to their local
drive, or they already have saved mails. Then they open mails via doubleclick
and Outlook Express starts and opens the mails instead of Thunderbird. I've
installed Thunderbird on several maschines, and a lot of people ask, why
Thunderbird is not able to open saved mails. This not a minor bug, this is a
migration bug. Seamonkey is able to register .eml files and shows the mails
within the browser. Other mail programs are able to register .eml files too.
Flags: blocking-aviary1.1?
Flags: blocking-aviary1.1? → blocking-aviary1.1-
This is a serious bug, in my opinion - why doesn't thunderbird open and read
it's own saved emails?  Silly to have to KEEP outlook express installed JUST so
I can read my saved client emails.  I hope this is going to be fixed, but so far
each release it is still an issue.
(In reply to comment #7)
> Mscott, this is one of the most confusing bugs for new users.
> New users will download and install Thunderbird, they will make Thunderbird as
> their default mail application. Maybe they will save some mails to their local
> drive, or they already have saved mails. Then they open mails via doubleclick
> and Outlook Express starts and opens the mails instead of Thunderbird. I've
> installed Thunderbird on several maschines, and a lot of people ask, why
> Thunderbird is not able to open saved mails. This not a minor bug, this is a
> migration bug. Seamonkey is able to register .eml files and shows the mails
> within the browser. Other mail programs are able to register .eml files too.
I'd say this should be a blocker, big time. Please reconsider that - rating.
Attached patch proposed fixSplinter Review
this registers our app as the handler for .eml, and saves the existing registry
settings. On unregister, we reverse it...
Assignee: mscott → bienvenu
Status: REOPENED → ASSIGNED
Attachment #184582 - Flags: superreview?(mscott)
Attachment #184582 - Flags: superreview?(mscott) → superreview+
Attachment #184582 - Flags: approval-aviary1.1a2?
Comment on attachment 184582 [details] [diff] [review]
proposed fix

a=shaver
Attachment #184582 - Flags: approval-aviary1.1a2? → approval-aviary1.1a2+
Status: ASSIGNED → RESOLVED
Closed: 16 years ago15 years ago
Resolution: --- → FIXED
David, why is the .eml file type not shown in the Windows folder options, if
Thunderbird is registered with .eml files?
Thunderbird only registers for .eml files when it registers itself as the
default mail client - so you have to uncheck that box, close the dialog, and
check it again. Or a new install gives you a chance to install thunderbird as
the default mail client.
This was only fixed for MAPI clients, see bug 300393.
I ran into a glitch on this patch:
I had, for quite some time, trunk builds in   C:\Moz\TB   which was set up as 
the default client.  I was checking the set-as-default functionality in the 1.5 
branch, which was installed under  C:\Moz\Thunderbird  ; everything seemed to be 
set up correctly, including the associations under the .eml key in HKCR 
(HKLM\Software\Classes -- I don't have a .eml key under the HKCU branch).  

That is, specifically:
  HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.eml\shell\open\command
had a default value of
  C:\MOZ\THUNDE~1\THUNDE~1.EXE "%1"

But double-clicking a .EML kept opening the trunk (1.6a1) build (unless, of 
course, 1.5 was already running).

So I started searching thru the registry, and encountered these keys:
  HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Applications\THUNDE~1.EXE
  HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Applications\thunderbird.exe

The former has a 'shell' subkey with 'FriendlyCache' and 'FriendlyCacheTime' 
values but default value and no subkeys.  The latter has a 'shell' subkey with a 
default value set to "open" and an "open\command" sub-branch; the 'command' 
subkey's default value was:   C:\Moz\TB\thunderbird.exe "%1"  -- that is, the 
trunk build.  When I reset that value to point to the branch build, double-
clicking a .EML file started up the branch.

So then I searched thru the registry to find another key pointing to 
"thunderbird.exe" -- and lo and behold, encountered this:
  HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\
     Explorer\FileExts\.eml
with a default value of:   thunderbird.exe

Maybe this isn't a problem for people who aren't running parallel installs of 
Thunderbird.
re: comment 15, ... And then what?
In my WinXP machine .eml opened in Outlook Express even though I had Thunderbird 1.5 as my default mail client. So after reading these messages, I set OE as default client, and then again TB as default, and now it works. I think that it would be better to register the file type correctly at install time, because I have had Thunderbird as a default e-mail client for ages, probably before this bug was fixed, so .eml was never registered correctly.
(In reply to comment #17)
> In my WinXP machine .eml opened in Outlook Express even though I had
> Thunderbird 1.5 as my default mail client. So after reading these messages, I
> set OE as default client, and then again TB as default, and now it works. I
> think that it would be better to register the file type correctly at install
> time, because I have had Thunderbird as a default e-mail client for ages,
> probably before this bug was fixed, so .eml was never registered correctly.
> 

Windows (XP-Svc Pk 2)

This bug is NOT "fixed" as of ver 1.5.0.8, as of 11/19/06.  I am running the user version of the app and not a developer version or a trunk or branch anything.

I read Comment #17.  Thereafter, as the comment indicated, I changed the default emailer from Thunderbird back to OE.  I then changed the default emailer back to Thunderbird.

NOTE:  Double-clicking the .eml file on my desktop did in fact launch TB, which did in fact launch the .eml file -- BEHIND the TB app window, AND the "c is not a registered protocol" error message got thrown.

Thus, although the author of Comment #17 is quite correct in stating that the change back to OE as default, with a re-set BACK to TB does in fact activate the file association between the .eml extension and the Thunderbird executable program file, the author of Comment #17's purported "fix" does NOT fix the underlying bug that launches the TB app with the email file loaded in a window BEHIND the TB app and the error message box in front of all of it.

This is still a MAJOR MAJOR MAJOE bug insofar as USERS are concerned; it drives them literally nuts, and they request that the email app be switched BACK to OE because Thunderbird "doesn't work."  Well, you know, and I know, that, from a programmer's point of view, TB does "work."  But that is NOT how the users see it.  All the users know is that they double-clicked a saved email file in order to read the file; and, instead of launching the email file in a window so they could read that ONE email file, they ended up with a program app window on TOP OF the file they wanted to read, AND there was an error message dialog box sitting on top of the app window, which, in turn, was sitting on top of the file window; and so they said to heck with it, we want OE back.

That's the bottom line.

So, will somebody PLEASE fix this bug.  This bug is by no means "fixed" -- as the status box above indicates -- at present insofar as the users are concerned.  Registering a file association is not rocket science.  The problem  here cuts so deep into the usability of the app that it is simply acting as a stupid impediment to adoption of the emailer by many.  As it now stands, even if one goes into the file association editing boxes in File Types and MANUALLY enters the correct text to create the file association, BOTH the uncalled for, and unwanted, main app window opening, AND the error message box still appear.  That is simply unacceptable to users, and I cannot fault them for their attitude about it.

L. Scott
(In reply to comment #18)
> NOTE:  Double-clicking the .eml file on my desktop did in fact launch TB,
> which did in fact launch the .eml file -- BEHIND the TB app window, AND the
> "c is not a registered protocol" error message got thrown.

That's bug 313457.
Status: RESOLVED → VERIFIED
Duplicate of this bug: 26201
You need to log in before you can comment on or make changes to this bug.