Popups displayed when viewing item properties in bookmark manager.

VERIFIED FIXED

Status

VERIFIED FIXED
14 years ago
9 years ago

People

(Reporter: ultimatedbz, Assigned: jst)

Tracking

({fixed-aviary1.0, fixed1.7.5})

Trunk
x86
Windows XP
fixed-aviary1.0, fixed1.7.5
Bug Flags:
blocking1.7.5 +
blocking-aviary1.0 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

Upon opening the Bookmarks Manager, right-clicking an entry, and opening its
Properties window, popups are displayed despite blocking being enabled. This
only occurs while the bookmarks manager and the properties window are both open.

Reproducible: Always
Steps to Reproduce:
1. Open Bookmark Manager.
2. Open any item's properties therein.
3. Browse to any page with a popup.

Actual Results:  
Popups were displayed.

Expected Results:  
Popups should have been blocked.

Comment 1

14 years ago
Confirmed this behavior. Quite odd.
Interesting.  Putting up a modal chrome dialog pushes some global popup state
that won't pop till the modal goes down, I guess?

This would be well-worth fixing on branches given that we've gone to all the
trouble of landing the new popup blocker there.
Flags: blocking1.7.x?
Flags: blocking-aviary1.0?
(Assignee)

Comment 3

14 years ago
Created attachment 160571 [details] [diff] [review]
Reset popup state while opening windows.

This should take care of that by resetting the popup control state while we're
opening windows, and that means that the state we had when we open a modal
dialog will not be active while the dialog is open, but it will be active again
when the dialog is closed, until we unroll the stack far enough to pop the
state that enabled popups in the first place.
Assignee: p_ch → jst
Status: UNCONFIRMED → ASSIGNED
(Assignee)

Updated

14 years ago
Attachment #160571 - Flags: superreview?(brendan)
Attachment #160571 - Flags: review?(bzbarsky)
(Assignee)

Comment 4

14 years ago
(In reply to comment #2)
> Interesting.  Putting up a modal chrome dialog pushes some global popup state
> that won't pop till the modal goes down, I guess?

Just to clarify, the act of opening up the modal dialog is a popup enabling
event (clicking in the menu) that enables popups while we're handling that
event, so what we need to do is to temporarily reset the popup state while
opening new windows to prevent the state from being active while the modal
dialog is open.
Comment on attachment 160571 [details] [diff] [review]
Reset popup state while opening windows.

Add a comment here explaining why the state is being pushed, and looks great!
Attachment #160571 - Flags: review?(bzbarsky) → review+
(Assignee)

Comment 6

14 years ago
Added:

        // Reset popup state while opening a window to prevent the
        // current state from being active the whole time a modal
        // dialog is open.
Want this for branches.

/be
Flags: blocking1.7.x?
Flags: blocking1.7.x+
Flags: blocking-aviary1.0?
Flags: blocking-aviary1.0+
Comment on attachment 160571 [details] [diff] [review]
Reset popup state while opening windows.

sr+a=me with the added comment.  Thanks,

/be
Attachment #160571 - Flags: superreview?(brendan)
Attachment #160571 - Flags: superreview+
Attachment #160571 - Flags: approval1.7.x+
Attachment #160571 - Flags: approval-aviary+
(Assignee)

Comment 9

14 years ago
Fixed on trunk, aviary and 1.7 branches.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Keywords: fixed-aviary1.0, fixed1.7.x
Resolution: --- → FIXED

Comment 10

14 years ago
*** Bug 261046 has been marked as a duplicate of this bug. ***
*** Bug 262980 has been marked as a duplicate of this bug. ***

Comment 12

14 years ago
*** Bug 263522 has been marked as a duplicate of this bug. ***

Comment 13

14 years ago
*** Bug 263723 has been marked as a duplicate of this bug. ***
*** Bug 266121 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.