Usable uninstall of search plugins

VERIFIED DUPLICATE of bug 232272

Status

()

Firefox
Search
--
enhancement
VERIFIED DUPLICATE of bug 232272
13 years ago
13 years ago

People

(Reporter: andrew.ferrier, Assigned: Pierre Chanial)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040911 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040911 Firefox/0.10

Although having installable search engines is a great idea, there is currently
no way for the average user to uninstall them. The only method I could find was:

http://kb.mozillazine.org/index.phtml?title=Firefox_:_FAQs_:_Uninstall_Search_Plugins

... which is not particularly user-friendly. Considering that uninstalling
engines is probably quite quite common (when I've installed Google UK the main
Google engine plugin will be useless and potentially confusing), I think it
would be helpful to add a 'Delete Engines...' to the drop-down that appears in 
the search box on the toolbar.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.




This might well depend on bug #259060 being resolved first.
(Reporter)

Comment 1

13 years ago
It would also help, I think, if the drop-down list of search engines could
be sorted by name. Currently they seem to be in install order, which is pretty
meaningless.
(Reporter)

Comment 2

13 years ago
My mistake: it appears the list of search plugins is re-sorted on load. This
is not ideal, but better than no sorting. I think my comments about uninstalling
are still valid, however.

Comment 3

13 years ago
yes, this is a problem especially to users who cannot access
/firefox/searchplugins/, who can add but not remove searchplugins

though almost all users can currently locate their /firefox/searchplugins/
directory to remove plugins, once they are relocated to the profile directory,
many more non-geek users will not be able to remove search plugins.

i'd recommend using shift delete in the drop-down menu (like in autocomplete) to
remove plugins, but requiring confirmation to remove (as confirmation is
required to add).

i'd use add/remove when describing searchplugins rather than install/uninstall,
because they're so ridiculously easy to handle.

*** This bug has been marked as a duplicate of 232272 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.