Download dialog box flickers and shifts to top left corner when opened

RESOLVED WORKSFORME

Status

()

Firefox
General
--
minor
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Wayne Woods, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; @AB_CD@; rv:1.8a4) Gecko/20040923 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; @AB_CD@; rv:1.8a4) Gecko/20040923 Firefox/0.9.1+

If you click on a link that initiates a download (such as the supplied URL),
then the download dialog box briefly appears off to the right of the browser and
then flicks across to the top left corner. This is the box that asks you how to
handle the file type ("Open With" or "Save to Disk"), so the above will only
work if it's not set to automatically download that file type.

Hardly more than a cosmetic issue.



Reproducible: Always
Steps to Reproduce:
1.Click on the supplied URL, observe shifting dialog box. 
2.If your browser is set to automatically download or open files of that type,
then try downloading a different file type, or reset the file type handling for
gzip files.
Actual Results:  
The dialog box opens in one place then quickly moves to a different one.

Expected Results:  
The dialog box should have opened and remained in a stable position.

This regression appeared between the 20040730 and 20040805 builds on the trunk.

As such, I wonder if it's another regression caused by the fix of bug 223545,
and thus related to the context menu problem in bug 257647. The latter bug was
fixed on the trunk by 20040918, but maybe a related fix is required for this one?
(Reporter)

Comment 1

13 years ago
Additional build info:

This bug seems to have first appeared in the 20040312 trunk build and persisted
until 20040726.

It seems to have been fixed (by chance?) in the 20040727 trunk, and the fix
briefly lasted until the 20040804 build. The 20040805 build shows the problem again.

Whatever patch fixed it must have only been checked into the trunk, as the
Aviary branch continued to display the problem during this period.

So it appears that the bug arose by some code change around 20040312, was fixed
by a trunk-only patch around 20040726 to 20040727, and recurred after another
code change around 20040804 to 20040805.
(Reporter)

Updated

13 years ago
(Reporter)

Comment 2

13 years ago
This bug seems to have been fixed between the 20041109 and 20041116 builds (I
don't have any builds in between to check). Something changed between those
dates so that the dialog box no longer gets moved to the corner at all. Looking
at bonsai, I have no idea what it was, but it's fixed anyway. :)
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.