The tab is functioning as a delete key in the compose mail window

RESOLVED INVALID

Status

Thunderbird
Message Compose Window
--
minor
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: Muzakkir, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

1. Open the compose window.
2. Enter the description and select the part of the message and click on the
tab, to increase the indent text towards right.
3. The text is getting deleted.
4. But the same thing doesn't happen if the text is selected with some bullets
or numbers.


Reproducible: Always
Steps to Reproduce:
1. Open the compose window
2. Select the text and hit on the tab key
3. The text is getting deleted.

Actual Results:  
The text that is selected should be moved towards right when the tab is selected.

Expected Results:  
The text that is selected is getting deleted when tried to move the indent
towards the right side, but working fine when moved using the bullets and numbers.

Thunder Bird :version 0.8 (20040913)
Theme :Noia 2.0 (eXtreme)

Comment 1

14 years ago
Reporter (Muzakkir) -- is this bug still a problem for you?  I cannot reproduce 
the symptom.
(Reporter)

Comment 2

14 years ago
Open the compose window, Enter some text 
Eg: 1.This is a sample 
    2.This is a sample
    3.This is a sample
Double click on the 2.This is a sample and click on the tab to move the text to
the right the selected text is getting deleted.

Comment 3

14 years ago
(In reply to comment #2)
> Double click on the 2.This is a sample and click on the tab to move the
> text to the right the selected text is getting deleted.

In the mail compose editors, <tab> is a character, not a function.  If you type 
'x' with text selected, the selected text would be replaced by 'x'.  What you 
are seeing is how the program is designed.

The workaround in this particular instance is to put the cursor before the '2', 
without selecting any text, then type the <tab>.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.