If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Changing CSS of chrome in DOM inspector crashes browser

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Aaron P, Assigned: Blake Ross)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10

When using DOM inspector on a chrome URL to change styles, the rule often
disappears and the browser subsequently crashes. This happens when changing the
style of just about any object. 

The crash problem did not happen in FireFox 0.9.3. I also tested this in Mozilla
1.7 (using navigator.xul) and, although the rule disappeared, the browser never
crashed and the rule seemed to be applied most of the time (which is why I
didn't put this under the "Browser" product). 

I thought about marking this critical, since it crashes the browser. However, I
can't tell if the problem is caused by a faulty DOM Inspector, or a bug in
FireFox that just happens to be triggered by DOM Inspector. In the past, the DOM
inspector has been invaluable at finding where to make style changes on the fly.
This is not possible anymore.

Reproducible: Always
Steps to Reproduce:
1. Open DOM Inspector
2. Choose chrome://browser/content/browser.xul and click Inspect
3. Find the node "toolbarbutton" with and id of "back-button". (Should be in
#document->window->toolbox->toolbar->toolbarbutton)
4. On the upper-right, select "CSS Style Rules"
5. Selct the rule ".toolbarbutton-1"
6. Right-click on the "min-width" property in the lower right and choose edit
7. Set min-width to 1px
8. Click OK
9. Entire rule disappears -- this shouldn't happen, but is more a DOM inspector
problem and should be filed as a separate bug.
10. Now close the DOM inspector and go to the main window and hover the mouse
over the back (<) button.
11. Browser crashes
Actual Results:  
Rule not applied right and browser crashes

Expected Results:  
Rule applied and browser does not crash

Usually get an exception accessing referenced memory at 00000000 or 00000001 and
the talkback program starts. I have sent a few reports in.

Comment 1

13 years ago
please try a recent build from
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/ and if
still crashes, submit a talkback report and post its id here.
Severity: normal → critical
Keywords: crash

Comment 2

13 years ago
I can confirm this happens on Firefox 1.0.1 UA string
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225
Firefox/1.0.1 StumbleUpon/1.9993

I was following his steps to reproduce as discussed in #bs, although the node I
inspected was olAttrBody.  When switching to view stylesheet rules instead of
DOM nodes, Firefox crashes.  Talkback ID is TB4515853H

Comment 3

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050321
Firefox/1.0+

Latest nightly, bug doesn't occur.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.