If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

RFE:<TABLE HEIGHT="100"> not reflected as tableEl.height

RESOLVED INVALID

Status

()

Core
Layout: Tables
P3
minor
RESOLVED INVALID
18 years ago
16 years ago

People

(Reporter: Martin Honnen, Assigned: vidur (gone))

Tracking

({testcase})

Trunk
Future
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: WONTFIX?)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Mozilla is using the HTML HEIGHT attribute for TABLEs so IN

<TABLE ID="aTable" HEIGHT="100" WIDTH="100" BORDER="1">
<TR>
<TD>
Kibology
</TD>
</TR>
</TABLE>

both width and height of the table are layout as specified. Now the table 
element
  document.getElementById('aTable')
has a 
  .width
attribute but not a
  .height
This assymmetry is around in the HTML 4 and DOM level 1 specs but I suggest to 
make
  .height
available too. Otherwise you have to teach people to script
  document.getElementById('aTable').width
but
  document.getElementById('aTable').getAttribute('height')
which seems unnecessary complicated and assymetric.

Comment 1

18 years ago
Reassigning to Vidur.
Assignee: karnaze → vidur
Summary: <TABLE HEIGHT="100"> not reflected as tableEl.height → <TABLE HEIGHT="100"> not reflected as tableEl.height
(Assignee)

Comment 2

18 years ago
As noted, table.height isn't a DOM Level 1 property. This is an RFE and will be 
pushed to M18.
Status: NEW → ASSIGNED
Summary: <TABLE HEIGHT="100"> not reflected as tableEl.height → RFE:<TABLE HEIGHT="100"> not reflected as tableEl.height
Target Milestone: M18

Updated

18 years ago
Keywords: makingtest
Whiteboard: hhsu@acm.org

Comment 3

18 years ago
Created attachment 7964 [details]
test case

Updated

18 years ago
Keywords: makingtest → testcase
Whiteboard: hhsu@acm.org

Comment 4

18 years ago
Uh. its broked in linux too.  This is really a crossplatform thing here.
shouldn't it be all/all?
This bug has been marked "future" because the original netscape engineer
working on this is over-burdened. If you feel this is an error, that you or
another known resource will be working on this bug,or if it blocks your work
in some way -- please attach your concern to the bug for reconsideration.
OS: Windows 95 → All
Hardware: PC → All
Target Milestone: M18 → Future

Comment 6

17 years ago
*** Bug 58387 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
QA contact update
QA Contact: chrisd → amar
Hmm.  I'd argue against this getting fixed because the table height attribute should only work in quirks mode-it's not standard.  If you're doing DHTML where you really need access to table dimensions, probably using getComputedStyle is a better way to go (although a lot of that isn't hooked up yet).
Whiteboard: WONTFIX?

Comment 9

16 years ago
I dont see it in any of the XHTML1.0/HTML4.1 DTD's.  Lets nuke this nonsense.
Zap. Hurrah for standards.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.