Adding new RSS feed doesn't store it in the selected folder

VERIFIED FIXED

Status

MailNews Core
Feed Reader
VERIFIED FIXED
13 years ago
6 years ago

People

(Reporter: jst, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
Create a new empty folder in your News & Blogs account and then go to add a new
RSS feed to the News & Blogs account and pick the new folder as the place to
store the messages from the feed. Thunderbird doesn't seem to realize that a
subfolder of the News & Blogs account was selected, and creates a new top-level
folder for the new feed, in stead of creating a new folder inside the selected
folder.

Comment 1

13 years ago
(In reply to comment #0)
I can't even get the feed to go into a folder. The only selectable folders when 
creating the new feed are the ACTUAL RSS feeds (also called folders themselves), 
not any subfolder's I've created.

For example, the field "Store Feed Articles in:" says "News & Blogs". When I 
click it I see my subfolders with arrows next to them, such as "General News >". 
Since Thunderbird considers the RSS feeds to be folders which store items, I 
cannot select a subfolder, but only a sub-subfolder (an actual feed). 
This is for version 0.8 (20041021).

Comment 2

13 years ago
Still exists in 0.9.

Comment 3

13 years ago
Clarification after testing on 0.9:

I think comment 1 is a different problem: basically it is impossible to select
any parent folder under "Store Feed Articles in" because selecting the parent
folder allows you only to select one of the children. This probably needs to
have a "Select this folder" option like the mail filters dialog does when
choosing a folder.

Top-level folders under News & Blogs account work fine, its only subfolders of
those that give the problem.

If a subfolder is selected as the destination of a feed, the feed instead gets
its own top-level folder created as if nothing had been selected.

Comment 4

13 years ago
*** Bug 261190 has been marked as a duplicate of this bug. ***
Either we need to fix this so that the messages  go there, or remove the ability
to create new folders or subfolders under an RSS account. Setting to 1.0 TM for
consideration.
Target Milestone: --- → Thunderbird1.0
(Assignee)

Comment 6

13 years ago
the xul template for the folder picker in the subscriptions dialog probably just
needs some template magic. 
Status: NEW → ASSIGNED
(Assignee)

Comment 7

13 years ago
Created attachment 166308 [details] [diff] [review]
the fix

David, I noticed if I create a sub folder and the try to attach a feed to it,
we fail because we don't have a database for the folder yet. If I load the
subfolder first, then the database gets created and I can then attach feeds to
it. I'm pretty sure there's another bug on record for something like that
already.
(Assignee)

Comment 8

13 years ago
fixed branch and trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 9

13 years ago
Verified this on the latest 0.9 build (2004-11-24-05). Discovered a new problem
that renaming parent folders doesn't get persisted properly, put that in bug
271697, but this is definitely working now...
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
Target Milestone: Thunderbird1.0 → ---
You need to log in before you can comment on or make changes to this bug.