memory leak if page contains a refresh meta-tag

RESOLVED WORKSFORME

Status

()

Core
Document Navigation
--
critical
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: Serhiy Matveyev, Assigned: Adam Lock)

Tracking

({mlk, testcase})

Trunk
mlk, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10

After evry reload page with meta http-equiv="Refresh" content="300" (300 -
sample) firefox-bin process enlarges memory ussage.

Reproducible: Always
Steps to Reproduce:
1. create html with auto-reload (<meta http-equiv="Refresh" content="3">)
2. fill html body (100kb-2Mb)
3. load the page into Firefox 1.0RC and watch firefox-bin memory ussage.
Actual Results:  
All free memory finish bit by bit.

Updated

13 years ago
Assignee: bugs → firefox
Component: Web Site → General
QA Contact: firefox.general

Comment 1

13 years ago
I have the same problem. A page with frames maintains status of various
applications. The overall frames-page has refresh meta-tag. Each frame has a
link to another frame containing a refresh meta-tag. These frames have static
HTML content.

The outer frame refreshes every 15 minutes. The inner frames refresh every 50 -
70 seconds (randomly generated times to not overwhelm the system). The inner
frames and static HTML are updated frequently by remote systems.

Firefox starts out at 20 MB, but slowly creeps up as the pages refresh. I
suspect the greater the static content, the faster the increase. Closing Firefox
and restarting gets it back to 20 MB.

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Windows 2000 Pro w/SP4 and all security patches (as of today, that is :-)

Comment 2

13 years ago
Created attachment 170339 [details]
Main HTML page that provokes memory leak

This is the main HTML source that provokes memory leaks. Over a range of 15
hours memory went from 12 MB to 119 MB just by viewing this page. This source
uses two other HTML files which are also attached.

Comment 3

13 years ago
Created attachment 170340 [details]
Second of three files for test case

This is the second of three files for the test case.

Comment 4

13 years ago
Created attachment 170341 [details]
Third of three files for test case

Third of three files for test case.

Comment 5

13 years ago
(In reply to comment #4)
> Created an attachment (id=170341) [edit]
> Third of three files for test case
> 
> Third of three files for test case.

I'm not sure these comments/attachments refer to the same thing as the reporter
is talking about... your problem seems to be more closely related to frames than
to meta-refresh. See Bug 52658, it may be what you're looking for.

Comment 6

13 years ago
Created attachment 175561 [details]
Large, simple HTML file with 3-second meta-refresh

This should show the bug, although it dosen't for me using FF1.0.1 on
WinXP/SP2.

Comment 7

13 years ago
*** Bug 287809 has been marked as a duplicate of this bug. ***

Comment 8

13 years ago
I've observed the meta-refresh bug as well.  We have a custom application where
Firefox is used as a human-machine interface (HMI).  The webpages all refresh
every 1 to 3 seconds, and over time, Firefox ends up using hundreds of megs of
memory.  This bug is particular pesky because we use Firefox as a user
interface, and it can reload the same page for months at a time.

Versions tested:
  Firefox 1.0.4
  Firefox 1.0.3
  Firefox 1.0.0
  DeerPark 1.0alpha

OS:
   Windows 2000, Service Pack 4
   Window XP Embedded, version 2002

Bug may be similar to 131456, which debt with memory not being released when
tabs were closed.  It might be that when reloading the page, the resources for
the original page are not freed. 

Comment 9

12 years ago
The following testcase causes my instance of DPa2:

Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8b3) Gecko/20050714 Firefox/1.0+

To leak 20MB/minute.
Keywords: testcase

Comment 10

12 years ago
(In reply to comment #9)
> The following testcase causes my instance of DPa2:
> 
> Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8b3) Gecko/20050714 Firefox/1.0+
> 
> To leak 20MB/minute.

Naturally, I forgot the testcase:

http://saturn5.com/~jwb/leak.html

Comment 11

12 years ago
The aforementioned test case also leaks like mad on:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006
Firefox/1.4.1

It leaks approximately 3MB per reload.

Updated

12 years ago
OS: Linux → All
Hardware: PC → All

Comment 12

12 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051018 Firefox/1.6a1

Bug is 100% reproduceable. 

Additional observation (only Linux): Memory consumed by X-server increases as well! after closing the tab, memory consumption stays constant, memory is not freed.
*** Bug 318008 has been marked as a duplicate of this bug. ***
Assignee: firefox → adamlock
Component: General → Embedding: Docshell
Product: Firefox → Core
QA Contact: general → adamlock
Version: unspecified → Trunk
Summary: memory leak if html contain the the refresh meta-tag. → memory leak if page contains a refresh meta-tag

Comment 14

12 years ago
Not seeing this with either the testcase from either comment 6 or comment 10, in trunk OR 1.8 branch nightly builds. Is this still a problem?
Keywords: mlk

Comment 15

12 years ago
I didn't test the trunk or the branch but the testcase for #10 is still a big leaker on Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

Comment 16

12 years ago
http://saturn5.com/~jwb/leak.html in 1.5.0.2:

BEFORE META REFRESH:

Leaked outer window 90b5c60 at address 90b5c60.
Leaked inner window 929f9a0 (outer 90b5c60) at address 929f9a0.
 ... with URI "http://saturn5.com/~jwb/leak.html".
Leaked document at address 9256210.
 ... with URI "http://saturn5.com/~jwb/leak.html".
Summary:
Leaked 2 out of 9 DOM Windows
Leaked 1 out of 30 documents
Leaked 0 out of 3 docshells


AFTER 1 META REFRESH:

Leaked inner window 9306cc0 (outer 90b5c40) at address 9306cc0.
 ... with URI "http://saturn5.com/~jwb/leak.html".
Leaked inner window 925e7f8 (outer 90b5c40) at address 925e7f8.
 ... with URI "http://saturn5.com/~jwb/leak.html".
Leaked outer window 90b5c40 at address 90b5c40.
Leaked document at address 93a2888.
 ... with URI "http://saturn5.com/~jwb/leak.html".
Leaked document at address 9299e70.
 ... with URI "http://saturn5.com/~jwb/leak.html".
Summary:
Leaked 3 out of 10 DOM Windows
Leaked 2 out of 31 documents
Leaked 0 out of 3 docshells


AFTER 2 META REFRESHES:

Leaked inner window 93a0070 (outer 90af1b8) at address 93a0070.
 ... with URI "http://saturn5.com/~jwb/leak.html".
Leaked inner window 937d528 (outer 90af1b8) at address 937d528.
 ... with URI "http://saturn5.com/~jwb/leak.html".
Leaked outer window 90af1b8 at address 90af1b8.
Leaked inner window 90a22f0 (outer 90af1b8) at address 90a22f0.
 ... with URI "http://saturn5.com/~jwb/leak.html".
Leaked document at address 9210ab0.
 ... with URI "http://saturn5.com/~jwb/leak.html".
Leaked document at address 95cf070.
 ... with URI "http://saturn5.com/~jwb/leak.html".
Leaked document at address 93a7328.
 ... with URI "http://saturn5.com/~jwb/leak.html".
Summary:
Leaked 4 out of 11 DOM Windows
Leaked 3 out of 32 documents
Leaked 0 out of 3 docshells


So that page leaks 1 outer window, and one inner window + 1 document each time it's loaded. The meta refresh doesn't leak anything iteslf, but just makes the page be loaded more times.



The testcase in comment 6 also shows nothing in 1.5.0.2. So I think it's safe to say there's no leak from a page containing a meta refresh.

-> WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.