If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

after form submit, cookies are not sent when view source is selected

RESOLVED INVALID

Status

Camino Graveyard
General
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Jon Stevens, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a4) Gecko/20040923 Camino/0.8+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8a4) Gecko/20040923 Camino/0.8+

Ok, this is a really hard problem to describe, so please be patient and read
everything as carefully as possible.

I have a page (foo.html) which can only be accessed when a proper cookie is sent
with the request (ie: you have to be logged in and the cookie has to be valid on
the server side).

The page has code in it like this:

<form method="POST" action="foo.html">
<select name="popupmonth" onChange="this.form.submit();">
...
</select>
</form>

Now, I can access this page just fine and I can view source on this page just fine.

The problem comes up whe I click the popup menu to submit the page with new data
, get a new page of html (which is fine), and then I try to *view source* on the
returned result.

In that case, when I view source, for whatever reason, the cookie is not being
sent/used again and the result is that I see different html than what I should
be seeing. I see my 'login' page which is what you get redirected to when the
session cookie is not sent.

Reproducible: Always
Steps to Reproduce:
(Assignee)

Comment 1

13 years ago
can you repro in firefox?
(Reporter)

Comment 2

13 years ago
I'm sorry for wasting time. Suddenly, I can't reproduce it in either browser.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.