Printing cannot handle translucency

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
5 years ago

People

(Reporter: roc, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Printing does not handle -moz-opacity. The fix in bug 260961 at least means we
don't crash, we just ignore it. But we need a solution. This will probably
depend on driving all opacity handling down into Gfx so we don't rely on being
able to get a pixmap. That in turn may depend on the anticipated move to using
Cairo as our universal rendering API.

Comment 1

13 years ago
*** Bug 252263 has been marked as a duplicate of this bug. ***

Comment 2

13 years ago
*** Bug 318946 has been marked as a duplicate of this bug. ***
Assignee: printing → nobody
QA Contact: printing

Comment 3

8 years ago
This bug is still alive and well in Firefox 4 (beta9).
See this simple test case (try print preview):
http://covertprestige.info/bugs/ff4-print-opacity/

Content with partial opacity is becoming more common with broad support for the CSS3 opacity property in all browsers (Chrome, Safari, Opera, and the future IE9), and broad use of JavaScript libraries such as jQuery that use opacity for animation effects.
For the record, I tested in Opera 11, Chrome 8 and Safari 5, and they handle printing of content with partial opacity just fine.
WFM on Windows. What platform are you testing, Florent? Our graphics code has changed enormously since this bug was filed, so whatever you're seeing now is really a new bug.
Actually, let me close this. Please file a new bug for your specific configuration.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.