save to disk and print feature

RESOLVED INVALID

Status

()

--
enhancement
RESOLVED INVALID
14 years ago
13 years ago

People

(Reporter: ricardosalta, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Maxthon; .NET CLR 1.1.4322; FDM)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040707 Firefox/0.9.2

I use the Web a lot for browsing news sites and printing out information (I 
love to read offline, but I always print in recycled paper). I don't know how 
to code, but I hope you'll like this idea and make it real.
I'd love to have a feature in Firefox that would enable me to enter a new 
mode, in which links I click remain in a list accessible by a menu (if I want 
to edit it for any reason).
That mode would be previously configured so that I could specify the format of 
the news URL and the format of the "print this page" URL. In this way, the 
links would pass by a search and replace operation.
Then, I'd have the possibility to fullscreen a slideshow with all the URLs in 
the list I built by clicking with that mode on.
By using left/right on the keyboard, I'd easily browse back and forward, like 
if I was reading in an old microfilm system in a library. Up and down would 
move the doc up and down smoothly. Eventually it would be nice to force a 
cache for this operation so the sites aren't unnecesarily overloaded with 
forward/back (Depends on how it's built, I know).
Then, I'd have some keys available in the fullscreen, with the possibility of 
doing simple automated macros. For things like:
1. Saving in a format as IE's "mht" preserving all the visual
2. Printing immediately with a predefined color/bw/quality
3. Saving as in number 1 but naming the file from the mouse-selected text 
instead of the document title
4. All these mixed
5. Any thing you can also imagine :)

This will speed up my news browsing like hours a week. I always print to read 
offline, and this would be a huge upgrade, for what I use a browser :)

Thanks in advance guys. And congratulations for this amazing project!

Reproducible: Couldn't Reproduce
Steps to Reproduce:
1.
2.
3.
1) dupe of bug 40873
2) ctrl+P
3) ?
4) ? 
5) ?

WONT ?

Comment 2

14 years ago
I don't really understand what you're asking for, but it sounds like you're
asking for something very similar to tabbed browsing.  Have you tried tabbed
browsing with fullscreen mode and the shortcuts for switching between tabs
(Ctrl+Tab, Ctrl+Shift+Tab, Ctrl+[number])?
(Reporter)

Comment 3

14 years ago
Of course there are approaches to what I imagine, but I searched and nothing
good enough exists that can really save me time.
One of the sites I use for news is http://ultimahora.publico.pt.
What I usually do, in SlimBrowser (I use this IE Upgrade because of the MHT
saving capability) is open all the news I'm interested in by clicking the scroll
button. They all open in background.
Then, I close the main tab and start a process that involves, for every open
page, checking the first one or two paragraphs and then decide if it's
interesting. If it is, I save it as an MHT with the name of the article (it's
not in the title - which is standard -, so I have to select the blue text and
paste it in the save dialog)
Then, after saving, I click the print button, and still have to click ok in the
print dialog.
Then, I still look up and down on the right-hand column to see if there are
latest news that interest me. If that happens, I print them out too. And save
them on disk.
As I hope you can see, this would benefit from an idiot-proof system to collect
URLs, give the possibility to apply a search-and-replace operation on that list
(to convert links to the printable version, if one wanted to do it - for me it
may be useful), and then have a fullscreen slideshow just as easy as ACDSee.
Left/Right to pass from page to page, and Up/Down to scroll the pages - smoothly.
Then some keys would be assigned, in order to immediately save and print, or to
save with the name as in the selected text and print, etc etc. All this
configurable.
Please make this real. It will boost my productivity soooo much!
And remember: I think of a better world. I use recycled ink and recycled paper :)
I just love to go out and walk the dog and go read everything in paper sitting
in the garden... real world rocks ;)
All the best to you guys!!
Ric
PS: As this fullscreen would be a new special mode, like the Microfilm mode or
something, the keys assigned would be as easy as possible, no CTRL+ etc. No need
for it I think. Good luck :)
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
too many things for i report
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.