<LI> ignored when its item is blank

RESOLVED DUPLICATE of bug 221855

Status

()

Core
Layout
--
minor
RESOLVED DUPLICATE of bug 221855
14 years ago
14 years ago

People

(Reporter: zhsoft88, Unassigned)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

when browse such content:

<ol>
<li>a
<li>
<li>b
</ol>

only display 1st <li> and 3st <li>  (<li>a and <li>b), 2st <li> doesn't display.

In IE, all of them will be displayed.


Reproducible: Always
Steps to Reproduce:
1.write a html file including such content:
<ol>
<li>a
<li>
<li>b
</ol>

2.browse it.
3.

Actual Results:  
only display 1st <li> and 3st <li>  (<li>a and <li>b), 2st <li> doesn't display.

Expected Results:  
all <li> should be displayed.

Comment 1

14 years ago
Created attachment 160453 [details]
testcase

I'm not seeing the empty LI not render, but I am seeing a broken render that
matches the testcase on bug 221855.

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 221855 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Keywords: testcase
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.