intl. prefs are not migrated from seamonkey

RESOLVED FIXED

Status

()

Firefox
Migration
RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: wolfiR, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a4) Gecko/20040928
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a4) Gecko/20040928

I think that the following prefs should be migrated from mozilla to firefox:

intl.charset.default
intl.accept_languages
intl.accept_charsets

Reproducible: Always
Steps to Reproduce:
.
(Reporter)

Comment 1

14 years ago
Created attachment 160457 [details] [diff] [review]
patch to migrate those prefs
on request of submitter
->NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

14 years ago
This patch is made against 0.10 (1.0PR) but I've seen no change on trunk.

Let me explain why I consider this important:
1. the UI for those settings is available in firefox since some time
2. the firefox default setting is en-US for intl.accept_languages
   This means that every http request requests en-US as accepted language
   This behaviour is not really good because "Multiviews" enabled webservers
   will always respond their pages for en-US instead their own default.
   e.g. webservers within de TLD will most likely use german as default language
   but if you connect with firefox you will get the english language.
   Because of this the UI is really needed and important (and was added 
   sometime ago)
   And therefore I recommend to migrate those settings out of an existing
   seamonkey profile.
(Reporter)

Updated

14 years ago
Attachment #160457 - Flags: review?

Comment 4

14 years ago
Please edit the file in place, and use "cvs diff -up
mozilla/browser/components/migration/src/nsSeamonkeyProfileMigrator.cpp" to
create the patch.

And you should request review from someone specific, like bugs@bengoodger.com.
(Reporter)

Comment 5

14 years ago
Created attachment 160470 [details] [diff] [review]
patch created with cvs diff
Attachment #160457 - Attachment is obsolete: true
(Reporter)

Updated

14 years ago
Attachment #160457 - Flags: review?
(Reporter)

Comment 6

14 years ago
Comment on attachment 160470 [details] [diff] [review]
patch created with cvs diff

the problem is that I don't know whom to ask for review. Thanks for the hint.
Attachment #160470 - Flags: review?(bugs)
Comment on attachment 160470 [details] [diff] [review]
patch created with cvs diff

mconnor, can you review this (IMHO trivial) fix? thanks
Attachment #160470 - Flags: review?(bugs) → review?(mconnor)
Comment on attachment 160470 [details] [diff] [review]
patch created with cvs diff

please replace the tabs with spaces and r=me.  Sorry for the latency.
Attachment #160470 - Flags: review?(mconnor) → review+
(Reporter)

Comment 9

13 years ago
Created attachment 175818 [details] [diff] [review]
same patch with corrected formatting
Attachment #160470 - Attachment is obsolete: true
checked in
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.