If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

MAILNEWS STATUS BAR: numerous errors

RESOLVED INVALID

Status

SeaMonkey
MailNews: Message Display
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: Meaker, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a4) Gecko/20040927
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a4) Gecko/20040927

I have noticed that the mailnews status bar is updated very poorly for numerous
operations. Frequently, messages are left on the bar from one operation while a
subsequent operation is in progress. There is generally poor attention given to
cleaning up and refreshing this important user notification area. It looks
sloppy and unprofessional. Looking through the bug list, I see a large number of
unresolved complaints about it. I suggest a small project be embarked upon by
one team member to look at the overall functioning of the status bar, and all
listed bugs related to it. Perhaps a new global subroutine should be written for
updating the bar, and it should be called after each operation (fetch mail,
compact folders, etc). Currently, this subroutine (if it exists) is only being
called sporadically and inconsistently, or status bar updates are being done all
over the place, and badly.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

13 years ago
Mozilla developers already know how to organise their work (I hope ;-) ).
Patches are always welcome, of course. :-) As you rightfully state, there are
already bug reports about specific issues with the status bar. This bug is more
a general rant than a useful bug report. Please read

http://www.mozilla.org/quality/bug-writing-guidelines.html

Thanks! :-)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> This bug is more a general rant

Calling my well-observed request for a coherent approach to a vexing,
long-existing and seemingly ineradicable set of flaws with mailnews a "rant" is
very disappointing, as well as insulting.

Will scale back my involvement with Mozilla bug reporting.

Comment 3

13 years ago
(In reply to comment #2)
> (In reply to comment #1)
> > This bug is more a general rant
> 
> Calling my well-observed request for a coherent approach to a vexing,
> long-existing and seemingly ineradicable set of flaws with mailnews a "rant" is
> very disappointing, as well as insulting.

I didn't mean to be insulting. :-( I'm not a native speaker. Obviously I chose
the wrong word. Sorry 10x for that! :-( I didn't know "rant" is such a hard
word, because I read it in blogs all of the time.

Nevertheless you should only report one specific issue per bug, not "a set of
flaws".
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.