Remove extension: fireFTP 0.87

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED FIXED
14 years ago
2 years ago

People

(Reporter: Mime Čuvalo, Unassigned)

Tracking

Details

(Whiteboard: needs-removing, URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

The excellent Firefox browser now has a brand new tool to go with it!
Introducing 'fireFTP', an FTP client which provides easy and intuitive access to
FTP servers.  Try it out!

Reproducible: Always
Steps to Reproduce:




Extension name: fireFTP
Version number: 0.82
Release date: 2004-09-25
Author name: Mime Cuvalo
E-mail address: mimecuvalo@gmail.com
URL to extension homepage: http://fireftp.mozdev.org/
URL to .xpi file: http://downloads.mozdev.org/fireftp/fireftp.xpi
Size of .xpi file: 50 KB

Updated

14 years ago
Assignee: psychoticwolf → jedsbugs

Updated

14 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 1

14 years ago
In queue. Should be up in a few hours/days.
Please re-open this bug for any updates.
Whiteboard: in queue
(Reporter)

Comment 2

14 years ago
On update.mozilla.org, can you change the homepage to be
http://fireftp.mozdev.org/  -- makes it look a little more official.

And can you please add to the description a new paragraph:
(This extension is still under development.  Updates will be made regularly)

Comment 3

14 years ago
It appears that the queue has been approved.  If your extension/theme was not
updated, please reopen this bug.  If you have an update, please remember to
clear the Status Whiteboard when you reopen this bug.  Thanks.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

14 years ago
The excellent Firefox browser now has a brand new tool to go with it!
Introducing 'fireFTP', a cross-platform FTP client which provides easy and
intuitive access to FTP servers. And unlike many other FTP clients, it's
completely free!

What's New in 0.83.1

A lot more ftp servers are supported (thanks to Devin)
Now works on OS X! (thanks to Jason Clark)
Fixed important upload bug (thanks to Bob Henson)
Ability to launch files from fireFTP
Remote symbolic links work
Support for ASCII files (notepad users rejoice!)
Ability to load fireFTP in a tab
Got rid of . and .. in directory listings
Tweaked favicon support
Changed homepage
Fixed minor problems with column sorting
If a directory is deleted, it is now removed from the cache
Other minor bug fixes

Extension name: fireFTP
Version number: 0.83.1
Release date: 2004-10-07
Author name: Mime Cuvalo
E-mail address: mimecuvalo@gmail.com
URL to extension homepage: http://fireftp.mozdev.org/
URL to .xpi file: http://downloads.mozdev.org/fireftp/fireftp.xpi
Size of .xpi file: 50 KB
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: in queue
(Reporter)

Comment 5

14 years ago
On second thought - the description is a bit lengthy (with listing what's new,
etc.)  Here it is revised:

The excellent Firefox browser now has a brand new tool to go with it!
Introducing 'fireFTP', a cross-platform FTP client which provides easy and
intuitive access to FTP servers. And unlike many other FTP clients, it's
completely free!
This latest version features support for: more FTP servers, OS X, ASCII files,
symbolic links, launching files from fireFTP, and loading fireFTP in a tab.
(Reporter)

Comment 6

14 years ago
Blah,
Please delay putting this 'in queue'.  I found some more critical bugs to the
program that'd I'd like to get fixed.
(Reporter)

Comment 7

14 years ago
Alright,
I apologize for being such a bother: here's the latest and greatest update. 
(the link to the .xpi file is not from the mozdev server b/c their download
mirrors take a while to update - thus, the latest version is on my site for now)

The excellent Firefox browser now has a brand new tool to go with it!
Introducing 'fireFTP', a cross-platform FTP client which provides easy and
intuitive access to FTP servers. And unlike many other FTP clients, it's
completely free!
This latest version features support for: more FTP servers, OS X, ASCII files,
symbolic links, launching files from fireFTP, and loading fireFTP in a tab.

Extension name: fireFTP
Version number: 0.83.2
Release date: 2004-10-08
Author name: Mime Cuvalo
E-mail address: mimecuvalo@gmail.com
URL to extension homepage: http://fireftp.mozdev.org/
URL to .xpi file: http://www.chasaidthekitty.com/hello/fireftp.xpi
Size of .xpi file: 50 KB
(Reporter)

Updated

14 years ago
Severity: enhancement → normal
(Reporter)

Comment 8

14 years ago
Whose leg do you have to hump to get a dry martini around here? :)

Seriously, you guys need some help?  If you're bogged down with work, you can
sign me up.  I'd be glad to lend a hand.
(Reporter)

Comment 9

14 years ago
I'm up to version 0.83.3 now.

Comment 10

14 years ago
You need to hump my leg ;)
Sorry, I'm a bit bogged down with school right now, if you serious about
helping, file a bug and Wolf or Alan could discuss it with you.

In Queue (0.83.3)
Status: REOPENED → ASSIGNED
Whiteboard: in queue

Comment 11

14 years ago
The queue has been approved.  Your files should now appear on UMO.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

14 years ago
The version number says 0.83.3 but downloading the .xpi gives the old .82 version.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: in queue
(Reporter)

Comment 13

14 years ago
As long as you guys are updating the old version to the new version - please
redownload the .xpi from http://downloads.mozdev.org/fireftp/fireftp.xpi

The new .xpi points to an update.rdf which will make fireftp download from
mozdev.org
(Reporter)

Comment 14

14 years ago
Correction: I meant http://www.chasaidthekitty.com/hello/fireftp.xpi
This site always has the latest .xpi

Comment 15

14 years ago
Mime, could you bump the version to.. say 0.83.4.
And I'll add it, if not I'll have to detele the 0.83.3 listing and then re-add
it which would mean it would be unavailable until approved by the queue.
Let me know if that would be ok. or what you would prefer.

Comment 16

14 years ago
Jed is busy for a while.  With his permission, I am reassigning to the default
component owner.
Assignee: jedsbugs → psychoticwolf
Status: REOPENED → NEW
Hardware: PC → All

Comment 17

14 years ago
Moving these off my list of code bugs, I'll work on them as I get time, and i'm
working on getting some more editors to help out. :-)

These need to be verified to work properly with the 1.0PR / latest-nightly (if
it's for 1.0RC1). Feel free to test and comment, that'll help speed up the process.
Assignee: psychoticwolf → mozilla.update
Keywords: helpwanted

Updated

14 years ago
Status: NEW → ASSIGNED

Comment 18

14 years ago
In Queue, Sorry for the delay.
Keywords: helpwanted
Whiteboard: in queue
(Reporter)

Comment 19

14 years ago
No need to be sorry, I think that the problem that was showing up on the update
site was my fault.  I had changed all the version numbers except the one in
contents.rdf which is where I now realize the site looks for information.  I'm
planning on releasing version 0.84 in a day or two so if you guys just want to
wait for that, it's not a problem.

Comment 20

14 years ago
Done.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED
Whiteboard: in queue
(Reporter)

Comment 21

14 years ago
version 0.84 is out
URL to .xpi file: http://www.chasaidthekitty.com/hello/fireftp.xpi
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 22

14 years ago
up to version 0.84.1 now
(Reporter)

Comment 23

14 years ago
and now we're up to 0.84.2

Comment 24

14 years ago
Reassigning to a temporary destination pending assignment to a new editor. :-)
Assignee: mozilla.update → firebot
Status: REOPENED → NEW
(Reporter)

Comment 25

14 years ago
thanks, wolf.
hey, i mentioned here before that if you guys needed an extra hand around
bugzilla i could maybe help.  where do you go to get drafted? :)  i'm not
promising i could be a full-time bugman (but i doubt any of you are) especially
b/c the internet connection here in croatia is costing me like $100/month (for a
dial-up, mind you).
but hell, i am unemployed and just twiddling my thumbs so i just thought i'd offer.

Comment 26

14 years ago
Assigning the bugs to Update's newest editor, nosebleed. :-) Please be patient
with him, as he's new, volunteering to help out and hopefully speed up the
process of getting these added.
Assignee: firebot → nosebleed
Severity: normal → enhancement
(Reporter)

Comment 27

14 years ago
Wolf, I don't know if you knew this but I was looking at nosebleed's blog and it
says that he'll be gone for awhile.  Check out the first entry on
http://blog.nosebleed.info/

My extension hasn't really been updated on u.m.o since Sep 29th (mostly my fault
I realize) It is really hurting the (45000!) users because the older version can
corrupt files on a person's machine, not to mention the loads of other bugs it
comes with.  Please update the extension as soon you can.
(Reporter)

Comment 28

14 years ago
Wolf,
It doesn't seem like you got my email: I'm reassigning this to you because I was
looking at nosebleed's blog and it says that he'll be gone for awhile.  Check
out the first entry on http://blog.nosebleed.info/

u.m.o is *still* offering version 0.82 which was a severely buggy alpha release.
(it has many critical bugs that can damage a user's files).  I hate to ask for
special treatment but this extension is a little different than others because
it's not so much an extension as it is an application.  *Please* update it as
soon as you can.  Just so I can sleep at night :)

p.s. I apologize for having to set this bug's severity higher - I just needed to
get your attention.
Assignee: nosebleed → psychoticwolf
Severity: enhancement → critical

Updated

14 years ago
Assignee: psychoticwolf → nosebleed
Severity: critical → enhancement

Comment 29

14 years ago
Due to unexpected circumstances, nosebleed is unable to handle these bugs
himself and won't be able to begin volunteering as he wanted to be able to.
Because we're already short-staffed, (alanjstr has been reassigning bugs off his
list and jed is unavailable till 10/25).

In order for these to be added to UMO they need to be tested for compatibility.

(From my blog post on the issue)
Basically what needs to happen is this:
- The new versions of each (probably near the bottom of the comments for each
bug) need to be tested on the newest version of the application (probably
Firefox or Thunderbird) that they're compatible with, if that's 1.0, then the
latest 1.0RC1 nightly, if it's only 1.0PR then the 1.0PR release.
- Extensions: Test and make sure they install and uninstall ok, and that they
add chrome to the browser UI that looks like it'll do what the author says it
will, and that the browser still works.
- Themes: Test that they install/uninstall ok and are complete, I.E. have all
the icons like Software Update and LiveBookmarks and that they don't break the
browser.

If they work, comment in the bug, and say you've tested it, and if it works or
not and the User_Agent of the browser (or Thunderbird version/buildid) you
tested with. (include the OS). (If you have editbugs permissions, add tested+ to
the status whiteboard, or if it fails tested-).

Once tested+ appears in the whiteboard, I'll reassign them to myself and add
them to the database. Thanks.
(Reporter)

Comment 30

14 years ago
this has been tested and it works.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041023
Firefox/0.9.1+
OS: Windows XP
Whiteboard: tested+
(Reporter)

Comment 31

14 years ago
by the way, URL to the latest .xpi is:
http://www.chasaidthekitty.com/hello/fireftp.xpi
(Reporter)

Comment 32

14 years ago
up to version 0.84.3
(Reporter)

Comment 33

14 years ago
my apologies, i downloaded the wrong installer.
tested+
works fine.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041024 Firefox/1.0
(Reporter)

Comment 34

14 years ago
Wolf, Alan, somebody,
Please.  Please.  UMO is still offering version fireftp 0.82 (not
0.83.3) which I've stated
repeatedly can corrupt user's files both locally and remotely and has
a host of other bugs and I've tried to get this changed for *2 weeks*
now.  This is damaging to the users and it's damaging the reputation
of the program.  All of my comments are saying 'buggy, doesn't work,
etc' and they're right!  Version 0.82 wasn't meant to be available for
so long (a month total now).   I don't like asking for special
treatment but really fireftp is an application and not just an
'extension'.

I'm on my knees here, guys.

If you ever do actually update it, maybe you'll even consider reseting
the comments somehow (maybe by deleting the extension altogether and
readding it) - fireftp has unjustly gotten a bad rap because people
are downloading the old testing version.

If you do not have the time now (and I realize you are busy), please
just remove the extension altogether from UMO.  That would be for the
best.
(Reporter)

Comment 35

14 years ago
Wolf, Alan, somebody,
Please.  Please.  UMO is still offering version fireftp 0.82 (not
0.83.3) which I've stated
repeatedly can corrupt user's files both locally and remotely and has
a host of other bugs and I've tried to get this changed for *2 weeks*
now.  This is damaging to the users and it's damaging the reputation
of the program.  All of my comments are saying 'buggy, doesn't work,
etc' and they're right!  Version 0.82 wasn't meant to be available for
so long (a month total now).   I don't like asking for special
treatment but really fireftp is an application and not just an
'extension'.

I'm on my knees here, guys.

If you ever do actually update it, maybe you'll even consider reseting
the comments somehow (maybe by deleting the extension altogether and
readding it) - fireftp has unjustly gotten a bad rap because people
are downloading the old testing version.

If you do not have the time now (and I realize you are busy), please
just remove the extension altogether from UMO.  That would be for the
best.

Comment 36

14 years ago
0.84.3 added, pending approval (which it'll get once i'm done adding. :-) )
Assignee: nosebleed → psychoticwolf
Whiteboard: tested+ → In Queue

Comment 37

14 years ago
Done. :-) Please wait for these to mirror, of course. Reopen for any updates.
Thanks.
Status: NEW → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED

Updated

13 years ago
Component: Update → Listings
Product: mozilla.org → Update
Version: other → unspecified
(Reporter)

Comment 38

13 years ago
Please update to version 0.86.1:
URL to latest .xpi: http://www.chasaidthekitty.com/firefox/fireftp_86_1.xpi

Please also change the homepage listed on u.m.o: it is http://fireftp.mozdev.org

And finally, change the description to read:
Introducing fireFTP, a cross-platform FTP client for Mozilla Firefox which
provides easy and intuitive access to FTP servers.  In addition to a compact
size (60 KB!) features include the ability to resume broken downloads, ability
to use fireFTP in a Firefox tab, support for passive or active mode, and support
for proxies.

-------------------

tested+
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
OS: Windows XP
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Whiteboard: In Queue → tested+

Comment 39

13 years ago
You can't tested+ your own extension.
Whiteboard: tested+
(Reporter)

Comment 40

13 years ago
well, then please assign someone to do so.
Whiteboard: need-testing

Updated

13 years ago
Assignee: psychoticwolf → Bugzilla-alanjstrBugs
Status: REOPENED → NEW

Comment 41

13 years ago
Tested 
(installed, used, configured, uninstalled, still alive)

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

Updated

13 years ago
Status: NEW → ASSIGNED
Whiteboard: need-testing → tested+

Updated

13 years ago
Summary: FTP client for Firefox → Update extension: fireFTP
Whiteboard: tested+ → In queue

Comment 42

13 years ago
Your item should now appear on the website.  Please reopen this bug for any
problems or updates.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago13 years ago
Resolution: --- → FIXED
(Reporter)

Comment 43

13 years ago
There is a new version available, version 0.87.

Please change the following things:
1.) Obviously, update the .xpi file.  New version can be found here:
http://www.chasaidthekitty.com/fireftp.xpi
2.) Add a screenshot for the program:
Thumbnail: http://fireftp.mozdev.org/images/fireftpthumb.jpg
Actual picture: http://fireftp.mozdev.org/images/fireftp.png
3.) Please also add fireFTP to the 'XUL Applications' category.  fireFTP is
after all one of these.

Thank you very much.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Summary: Update extension: fireFTP → Update extension: fireFTP 0.87
Whiteboard: In queue → need-testing

Updated

13 years ago
Assignee: Bugzilla-alanjstrBugs → nobody
Severity: enhancement → normal
Status: REOPENED → NEW

Comment 44

13 years ago
Reopen when you're out of beta.
Status: NEW → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 45

13 years ago
"Reopen when you're out of beta"?  You're kidding me - listen: this extension's
been around since September back when it was an alpha and you have been listing
it since then.  The fact that it is in 'beta' doesn't mean it doesn't work.  I
mean look at Gmail or Froogle!  These are working products that *Google* puts
out.  There is nothing wrong with being a beta.

Please reconsider your position.  If you don't wish to list it then please just
remove it altogether from u.m.o.  If you can read from all of the comments I
made since September: I'm sick and tired of having to literally fight for the
right to make an update.  It's more work than actually writing an extension! 
The people that make extensions do so voluntarily without pay (as do you with
working on u.m.o) but we as extension writers are made to feel like were at some
beaurcratic institution (e.g. the DMV), waiting in line forever until our number
is called.  And then when the number is called you tell us - oh, you forgot form
A-47F, go to the back of the line.  I've been waiting for nearly a month for a
response and now because of a simple word change you tell me wait another month!
 Look at any other extension that you've recently added - they all have version
numbers like ViewSourceWith 0.0.4, Longdesc 0.21.  I guess they're all full,
working, bug-free pieces of software, right?

Show some heart guys.  I thought this is what the open source movement was all
about - being able to put some soul in the machine.

You need to reopen the developers section on u.m.o.  Then you and I will all
stop having to bother each other.

Sincerely (and holding back as much bitterness as humanly possible),
Mime Cuvalo

p.s. Don't bother responding to what I just said - I'm venting.  Either update
it or remove it.  I wished I cared either way anymore.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Summary: Update extension: fireFTP 0.87 → Update (or remove) extension: fireFTP 0.87
(Reporter)

Comment 46

13 years ago
Disregard earilier comments and please remove my extension from u.m.o.  I will
rerelease it once it reaches version 1.0

Thank you.
Summary: Update (or remove) extension: fireFTP 0.87 → Remove extension: fireFTP 0.87
Whiteboard: need-testing → needs-removing

Updated

13 years ago
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
AMO BUGSPAM FOR COMPONENT MOVE AND DELETE (FILTER ME)
Component: Listings → Web Site
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.