When using user drop down lists, cc drop down should be multi-select

RESOLVED DUPLICATE of bug 255428

Status

()

Bugzilla
User Interface
RESOLVED DUPLICATE of bug 255428
14 years ago
6 years ago

People

(Reporter: Shankar Unni, Assigned: myk)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

When "usemenuforusers" is enabled, the "Add cc:" becomes a drop-down list, but
it's a single-select list. 

Which means that if I need to add 3 or 4 people to the cc: list, it becomes a
tedious exercise.

The Add CC: dropdown list should be <select multiple="yes" ...>.

Reproducible: Always
Steps to Reproduce:
1. Turn on "usemenuforusers".
2. Edit a bug.
3.

Actual Results:  
The Add CC: drop-down list only allows one entry to be selected.

Expected Results:  
The Add CC: drop-down list should allow zero or more entries to be selected.
(Reporter)

Comment 1

14 years ago
Created attachment 160573 [details] [diff] [review]
Suggested patch for multiple-select Add cc: list

Suggested patch.

Updated

14 years ago
Attachment #160573 - Flags: review?
Comment on attachment 160573 [details] [diff] [review]
Suggested patch for multiple-select Add cc: list

--- template/en/default/bug/edit.html.tmpl	18 Sep 2004 11:33:10 -0000     
1.43
+++ template/en/default/bug/edit.html.tmpl	29 Sep 2004 22:05:12 -0000
@@ -174,6 +174,8 @@
	     accesskey => "a"
	     size => 30
	     emptyok => 1
+	     multiple => 1
+	     selectsize => 3
	   %]
       </td>
     </tr>

The line "emptyok => 1" should be removed. That way, multi-select boxes may
still have no selection, and it looks a little better to me without an empty
leading line.
It works well, so I'd say it's good apart from that.
Attachment #160573 - Flags: review? → review-
masscc in edit-multiple.html.tmpl could also be converted to a multiple-select
as part of this patch.

Updated

14 years ago
OS: Windows XP → All
Hardware: PC → All

Comment 5

14 years ago

*** This bug has been marked as a duplicate of 255428 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.