Background Images are severely shrunken when printed

RESOLVED DUPLICATE of bug 161179

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 161179
14 years ago
13 years ago

People

(Reporter: James Yopp, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

Pages look fine in the browser and in Print Preview, but when they are printed,
all the background images are scaled down -- they print pixel-for-pixel at the
printer's resolution, resulting in an incredibly small image on the printed page.

Background images (eg., multi-state buttons with state-shifting backgrounds)
should be scaled and clipped the same as any other image.

Reproducible: Always
Steps to Reproduce:
1.Go to a site that has CSS background images
2.Turn on "Print Background" in Page Setup
3.Print the page

Actual Results:  
Printed images are very, very small (depending on the printer's native resolution)

Expected Results:  
FireFox should scale and clip background images the same as any foreground image.

Comment 1

14 years ago
I've recently discovered the same problem. If the image is used as a background
of a div the image shrinks when you print the page even though it shows
perfectly fine in print preivew.
For a good example of this background printing wierdness:
http://www.hotdesign.com/seybold/everything.html .  Try printing some pages of
that document with "print background" selected in Page Setup (and print it
landscape for the layout to work).  This only happens on the print-out; not with
print preview.

Comment 3

14 years ago
I had this behavior on a page I was designing, and found a "solution":

The shrinking only happened when the background image of the div was set to not
repeat, whether horizontally, vertically or both. When the background image was
set to repeat in both directions, and the div was sized to exactly the size of
one instance of the background image, it prints fine. This is what was true for
me, anyway.

Comment 4

13 years ago
Another site to see this verified on would be zeldman.com. The main image
rollovers are severely shrunken when printed out. 

Simply getting the "print preview" to show the shrunken images would be a major
step forward, as right now must website designers have no clue how horribly
their site is rendered unless they manually print out *every page* of their site. 

The last "solution" currently listed here does partially work, but in some of my
images, I'm unable to set the div to the proper size precisely because I want to
cut off some of the images using css selectors. Please, if you can, confirm and
fix this bug!

Comment 5

13 years ago
Created attachment 186924 [details]
another test case

I have the same problem with the image being reduced in size. The printed
version and print preview versions also show 4 images instead of 2.

ff 1.0.4

Comment 6

13 years ago
I found the same problem in the latest release of Mozilla and Firefox

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.11) Gecko/20050728
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.10) Gecko/20050716
Firefox/1.0.6

Comment 7

13 years ago
(In reply to comment #6)
> I found the same problem in the latest release of Mozilla and Firefox
> 
> Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.11) Gecko/20050728
> Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.10) Gecko/20050716
> Firefox/1.0.6
> 
> 

Fixed it by addnig background-repeat: repeat to stylesheet.

Comment 8

13 years ago
(In reply to comment #4)

The result can be tested by using Adobe Acrobat PDF Maker/Writer, the output is
the same as on paper but doesn't use paper.

Comment 9

13 years ago
Created attachment 193928 [details]
print output using adobe acrobat 6.0 pro with firefox 1.06 

(In reply to comment #3)

After trying a few different options of the background-repeat and different
size images I also noticed something else with the repeat option. It looks ok
in Print Preview but on paper it tiles the images until it runs out of room for
another complete image and then crams that one in the remain space. I will try
to attach a pdf document showing this and the html/css used for this.

Comment 10

13 years ago
Created attachment 193932 [details]
testcase html used to create pdf output 

test case
Assignee: firefox → nobody

*** This bug has been marked as a duplicate of 161179 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.