If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Downloads silently fail when connection is broken.

RESOLVED INCOMPLETE

Status

()

Toolkit
Downloads API
RESOLVED INCOMPLETE
13 years ago
9 years ago

People

(Reporter: Michael Robinson, Unassigned)

Tracking

1.7 Branch
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10

Firefox will start a download, the download manager will show the download is
complete, but i will be left with an incomplete file. (it does delete the .part
file).

This happens sporadicly for no apparent reason.  I did not have problems with
earlier versions of Firefox.

Reproducible: Sometimes
Steps to Reproduce:
1.
2.
3.



Expected Results:  
Produced an error message or completed the download.

Comment 1

13 years ago
*** Bug 262493 has been marked as a duplicate of this bug. ***

Comment 2

13 years ago
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8b2) Gecko/20050220 Firefox/1.0+

I am not able to reproduce this one.

Reporter, can you try this with a nightly build and a clean profile? If it's not
still an issue, please resolve this WORKSFORME. If it is, (and if possible)
please try and find a way to reproduce this.
(Reporter)

Comment 3

13 years ago
I am surprised to see this bug is still open.  I thought it had been marked as a
duplicate of another bug and I am 99.9% certian it was fixed before 1.0 was
released.  I rember a critical update warning in the preview releases about data
loss in downloads and assumed it was the same bug.

I'm gonna change the resolution to invalid.

Hopefully this should preven furthor confusion.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

13 years ago
This bug can be reproduced by:

1.  Downloading a large file from some server with firefox.
2.  Shutting down the server before the download completes.

Firefox behaves as if the download has completed and leaves a truncated file.

I have tested this with a local instance of apache 2, firefox 1.0.1., and a
300mb+ file.

I think a couple months of better than usual service from my isp lead me to
think this bug had been fixed.
Status: RESOLVED → UNCONFIRMED
Hardware: PC → All
Resolution: INVALID → ---
Version: unspecified → 1.0 Branch

Comment 5

13 years ago
I see a similar problem using windows 2K

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.7) Gecko/20050414
Firefox/1.0.3  

I've only seen this with files bigger than 1MB.  File size in not known
but download manager.  It has failed with files about 1.2MB, and biggest
I've tried is 3.5 MB

I am able to download the same files immediately using internet explorer,
so regardless of the ISP behavior a different browser does not hang.

I had no problems using 1.0.1, 1.0.3 was installed recently and the problems
started.

Comment 6

13 years ago
*** Bug 276254 has been marked as a duplicate of this bug. ***

Comment 7

12 years ago
First off: Please change the summary of this bug to something meaningful, as I had a hard time finding it.
e.g. "Download (HTTP, FTP) appears completed if transfer stops mid way"

Confirming this bug with the trunk build on linux.
Comment 4 is right in that this bug is ALWAYS reproducible with the steps noted. It happens no matter how big or small the downloaded file actually is, though it obviously requires more accurate timing with small files. I was able to reproduce the bug both with HTTP and FTP transfers by killing the server process during the transfer, even on localhost, every single time. The download manager then shows the download as being "done", when it is clearly not. 

This behaviour is IMHO worse than bug 265828 (which is different) because it gives the user the impression that the download was completed successfully. The absolute minimum required in this situation would be some sort of error indication that tells the user that the download is broken / incomplete. Severity>major anyone?

I don't think this bug is Linux-OS-specific either. On a side note the wget and ftp tools can handle the described situation just fine and show meaningful error messages in any event.

(Tested against vsftpd for FTP and python's SimpleHTTPRequestHandler for HTTP on the server-side)
(Reporter)

Comment 8

12 years ago
I made the summary a bit more descriptive
Summary: Downloads Stop Mid Way → Downloads silently fail when connection is broken.

Comment 9

11 years ago
I have had this same problem in Internet Explorer before.

Today was the first time that Firefox did this to me.  I was downloading 4 files that were each over 290 MB.  I started the downloads all around the same time.  They all say "Done," but all 4 files are only between 188-197 MB.  I am running the latest version of Firefox.  

I have a possible solution to this problem.  Anytime that the server initially states that a file size is X, and the download stops at size Y, which is less than X, the user could be given an option to resume the download, in the same manner as resuming a paused download.  

Comment 10

11 years ago
Still an issue with 1.5 - start downloading, break the connection, and FireFox claims it's finished and leaves you with a bogus file.  100% reproducible.

Comment 11

11 years ago
This bug is specially disturbing when You're using a GPRS dial-up with a mobile phone. If you're moving while downloading something big, i.e. couple of megabytes, for sure there will be some gaps in the connection during RA updates, voice calls, incoming SMS's etc. This is really a showstopper from the viewpoint of a mobile user. I am seeing this all the time with the newest releases when using mobile connections. I am using Windows XP.

Comment 12

11 years ago
I have experience this before, esspecially if the file is about 6mb and above, i have reproduced this problem by doing the following

1.Go to any manga dowload site
2.Dowload any file which is at 6mb and above


Sometimes it goes through, and i've tested by having a lot of torrents to kill my bandwidth and also by only having Firefox on. And like all the other replies the .part file disappears.

On top of that, my connection has not died at all during this time.

Comment 13

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-GB; rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

I discovered this bug recently whilst using a 3G connection and downloading files. My connection is prone to disconnecting, and upon disconnecting my current downloads will appear as completed when they are not.

It's worth noting that the FTP site I'm currently downloading from does not support resuming and does not show maximum file sizes when you are downloading. I don't know much about FTP so I'll let the more knowledgeable interpret that.

Here is a URL to one of the files on the same FTP:
ftp://ragnarok.nefficient.co.kr/pub/ragnarok/Patch/2006-12-27adata_k6.gpf

The file is 9759KB, but I have experienced this problem with files smaller than 1MB.

Updated

11 years ago
QA Contact: ali → download.manager

Comment 14

11 years ago
Firefox version 1.5.0.4
with disconnection the partial downloaded file is declared complete. Help says to press retry option for resuming download but there is no retry option available. Actually this happend when I tried to download Firefos version 2 to upgrade. The next try again started afresh. With dial up line it is frustrating to retry a fresh after 2MB download.

Comment 15

11 years ago
Firefox version 1.5.0.4, Windows XP version
with disconnection the partial downloaded file is declared complete. Help says to press retry option for resuming download but there is no retry option available. Actually this happend when I tried to download Firefos version 2 to upgrade. The next try again started afresh. With dial up line it is frustrating to retry a fresh after 2MB download.
Assignee: bugs → nobody
Does this still happen with 2.0.0.4 or the latest nightly?
I just tested this on the latest nightly (build 2007080704) and I cannot reproduce this behaviour.

I went to ftp.mozilla.org and started to download Firefox 2.0.0.6 enUS.  Once the download got about 40% done, I disabled my wireless card and the download progress was halted.  I kept my wireless off for about a minute, at which point I re-enabled my wireless card.  After a connection was established, the download automatically continued.  The downloaded file worked with no problems.

Reporter, if you still witness this behaviour on the latest version of firefox, please post your comments.  If you do not experience the problem anymore, please resolve this bug as WORKSFORME.

This bug will be resolved incomplete in 2 weeks if there are no more comments.
Whiteboard: CLOSEME 08/21
Due to lack of reporter feedback and the inability to reproduce this bug, it is being resolved as INCOMPLETE.  Reporter, feel free to reopen this bug if you still are experiencing this issue and wish to provide us with more information so that we can help.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago10 years ago
Resolution: --- → INCOMPLETE
Whiteboard: CLOSEME 08/21

Comment 19

10 years ago
(In reply to comment #17)
> I just tested this on the latest nightly (build 2007080704) and I cannot
> reproduce this behaviour.
> 
> I went to ftp.mozilla.org and started to download Firefox 2.0.0.6 enUS.  Once
> the download got about 40% done, I disabled my wireless card and the download
> progress was halted.  I kept my wireless off for about a minute, at which point
> I re-enabled my wireless card.  After a connection was established, the
> download automatically continued.  The downloaded file worked with no problems.
> 
> Reporter, if you still witness this behaviour on the latest version of firefox,
> please post your comments.  If you do not experience the problem anymore,
> please resolve this bug as WORKSFORME.
> 
> This bug will be resolved incomplete in 2 weeks if there are no more comments.
> 

(In reply to comment #17)
> I just tested this on the latest nightly (build 2007080704) and I cannot
> reproduce this behaviour.
> 
> I went to ftp.mozilla.org and started to download Firefox 2.0.0.6 enUS.  Once
> the download got about 40% done, I disabled my wireless card and the download
> progress was halted.  I kept my wireless off for about a minute, at which point
> I re-enabled my wireless card.  After a connection was established, the
> download automatically continued.  The downloaded file worked with no problems.
> 
> Reporter, if you still witness this behaviour on the latest version of firefox,
> please post your comments.  If you do not experience the problem anymore,
> please resolve this bug as WORKSFORME.
> 
> This bug will be resolved incomplete in 2 weeks if there are no more comments.
> 
you will be able to reproduce it if you keep the wireless card off for longer than a few minutes. When you have connection off for only a min or so, you wont notice it since it has not reached the threshold for failing the transmittal...

Comment 20

10 years ago
Resolve this bug as WORKSFORME.
(In reply to comment #20)
> Resolve this bug as WORKSFORME.
> 

I have no problems changing the resolution for you, however, I would like to know why.  I can assume that you tested this and it works fine for you.  Please reply with what you did to test and what your results were.  We cannot just resolve a bug because people say it works.  Thanks.
Duplicate of this bug: 250003
Comment 13 and comment 19 seem to report that FF v2 *is* affected.

Reopen, if you can reproduce, and give as much details (= example) as you can.
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.