bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

about:config should be reachable thru the Tools:Options UI

RESOLVED DUPLICATE of bug 249323

Status

()

Firefox
Preferences
--
enhancement
RESOLVED DUPLICATE of bug 249323
14 years ago
12 years ago

People

(Reporter: Sean M. Burke, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040803 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040803 Firefox/0.8

Getting at the usefulness of the "about:config" screen shouldn't require the
user, even the advanced user, to remember the exact "about:..." URL to enter. 
(Can you tell I just spent a while fumbling around for "about:preferences" and
"about:prefs" and "about:options" and "about:opts", "about:*" and whatnot?)

I suggest putting an option on the Tools:Options:Advanced pane -- maybe call it
"Raw Preferences View" or something -- that would bring up the "about:config"
screen.


Reproducible: Always
Steps to Reproduce:
1.  SMS all your friends asking if they remember what the magic Firefox thing is
that brings up all the preferences, because you can't remember "about:config" or
find it in any of the menus or in the Tools:Options UI.
2.  When none respond, try typing "about:preferences" or the like, since you
know it's something like that.
3.  Stare pathetically into space as exactly /nothing/ happens when you enter
"about:preferences", etc
Actual Results:  
Shame spiral.  Crying.  Bonghits.

Expected Results:  
I'd have looked in the Tools:Options UI, selected Advanced, seen something like
"Raw Preferences View", clicked it, and gotten what is currently accessible only
by remembering the magic URL "about:config".  Then I would have been happy, and
had cake.

*** This bug has been marked as a duplicate of 249323 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.