Browser tab focus appearance is ugly

RESOLVED WORKSFORME

Status

SeaMonkey
Themes
RESOLVED WORKSFORME
14 years ago
8 years ago

People

(Reporter: Jaagup Irve, Unassigned)

Tracking

({modern})

Trunk
x86
Windows 98
modern

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
I am using Modern skin, Suite 1.8alpha4

1. Make the tab bar appear (CTRL+T)
2. Click on the selected tab again.

Result: An ugly box appears around the tab. It does nothing useful, I cannot
copy the contents so it's useless to me and I get annoyed if it happens since I
feel something is wrong.

I suspect that this is a dupe or is a result of "fixing" some bug. Thus it
starts out unconfirmed.

Comment 1

14 years ago
The focus is useful. Once you have focus in a tab, left/right arrow switches
tabs. This is intentional. For one thing it allows screen reader users to
traverse tabs, hearing the name of each tab as they move. It's also how tabs
work in other apps.

Do you mind posting a screenshot of the ugliness?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Browser tabs are selectable with click, thus get ugly → Browser tab focus appearance is ugly
(Reporter)

Comment 2

14 years ago
Created attachment 160657 [details]
Picture of tab focus on Modern

Ok, I understand the accessibility issues of tab focusing. It might be
impossible for one to press CTRL+PgUp simultaneously without effort. Yet I feel
that the visual feedback of selection should be made less intrusive and
misleading. Box shows selected area as in tables (try to click in a table cell
while holding CTRL to see what I mean) and focus on tabs. Bad. The standard
practice, I think, would be a dotted line around the text to show the focus.

What I feel with the current setup, is that I have just unintentionally
selected a tab and it won't go away when I click outside the tabbed area. I
would probably never have found the right-left arrow trick on my own. Yet I
tried to find its function by trying to copy, then paste the title text into
some textarea, unsuccessfully.

Also, clicking the area on tab-bar that is not used by tabs should take the
focus away from tab, I think. Separate bug probably.
Another important use of focusing tabs is to be able to close XUL documents in
the content area (eg webapps) with a keyboard shortcuts.  Since the XUL document
itself is not focusable, the only way to do that is to focus the tab and then
hit ctrl-w.

Comment 4

14 years ago
One can agree that tabs should be focused, but it doesn't really make sense to
focus it when the user click on them.

The focus should only be shown when the user tabbed into it. Normal Windows
applications that have tabs in dialogs act like this. For example, Internet
Explorer Options dialog and all tabs within the normal UI of Windows, like
Display Properties and others.

Comment 5

13 years ago
Kai: At least on Windows XP, tabs DO act like those in Firefox. For example, open IE's Tools->Options and click the current tab. It gets a dotted focus rectangle.
(Assignee)

Updated

10 years ago
Product: Core → SeaMonkey

Comment 6

8 years ago
WFM in the Modern Theme
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101102 SeaMonkey/2.1b2pre
Assignee: tabbed-browser → nobody
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Component: Tabbed Browser → Themes
Keywords: modern
QA Contact: themes
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.