If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add extension: SearchStatus

RESOLVED FIXED

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED FIXED
13 years ago
2 years ago

People

(Reporter: Craig, Assigned: alanjstr)

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

SearchStatus 1.0.0 by Quirk

SearchStatus provides extensive search-related information about a site,
including the Google PageRank and Alexa popularity, all conveniently displayed
in one discreet and compact toolbar.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Updated

13 years ago
Assignee: psychoticwolf → jedsbugs
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

13 years ago
Please include url next time.. taking..
Status: NEW → ASSIGNED
(Reporter)

Comment 2

13 years ago
URL is http://www.quirk.co.za/searchstatus/

This was specified in the URL field above.

Comment 3

13 years ago
OK, I meant direct links to the xpi's but that's ok.
Few issues
1) FX version -> max need to be set to 0.10 (1.0 hasn't been released yet)
2) Moz version can't have the firefox install.rdf stuff in it if it's really a
seperate xpi. (although should/optionally have an install.rdf with mozilla suite
info see: http://forums.mozillazine.org/viewtopic.php?t=99246)

Marking as invalid until this is fixed. Thanks, please re-open when these
changes are avaiable.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

13 years ago
Thanks for taking the time to clarify.

I have released ver 1.0.1 which has the necessary changes. Here are the direct
links:

Firefox: http://www.quirk.co.za/searchstatus/searchstatus-1.0.1.xpi
Mozilla: http://www.quirk.co.za/searchstatus/searchstatusmoz-1.0.1.xpi

Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Comment 5

13 years ago
Thanks, but, I'm still geting a max version of 1.0.0 (shoulc be 0.10) for Firefox
and the mozilla version still have the firefox info in it.
Thanks.

Updated

13 years ago
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 6

13 years ago
Sorry about that, there must have been a mixup when transferring to the server.
I have corrected this and tested both - there is now a max version of 0.10 and
no install.rdf in the Mozilla version.

Direct links are as above.

Thanks.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Assignee)

Comment 7

13 years ago
Jed is busy for a while.  With his permission, I am reassigning to the default
component owner.
Assignee: jedsbugs → psychoticwolf
Status: REOPENED → NEW
(Assignee)

Updated

13 years ago
Summary: SearchStatus 1.0.0 extension by Quirk → Add extension: SearchStatus

Comment 8

13 years ago
Moving these off my list of code bugs, I'll work on them as I get time, and i'm
working on getting some more editors to help out. :-)

These need to be verified to work properly with the 1.0PR / latest-nightly (if
it's for 1.0RC1). Feel free to test and comment, that'll help speed up the process.
Assignee: psychoticwolf → mozilla.update
Keywords: helpwanted

Updated

13 years ago
Assignee: mozilla.update → psychoticwolf
Keywords: helpwanted
Whiteboard: tested+

Updated

13 years ago
Status: NEW → ASSIGNED

Updated

13 years ago
Whiteboard: tested+ → In Queue

Comment 9

13 years ago
Fixed. These items are now listed.. If all else fails, make the time to test. :-)
As usual, reopen the bug for any problems/updates. Thanks.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

13 years ago
Sorry to be dense, but I'm a little lost here. I'm currently running with 1.0PR
- do you need me to test with the latest nighlty?

Comment 11

13 years ago
(In reply to comment #10)
> Sorry to be dense, but I'm a little lost here. I'm currently running with 1.0PR
> - do you need me to test with the latest nighlty?

Nope, Comment #8 was written when i thought I'd need more help to get the
pending requests handled in a timely fashion. :-) Your extension has been posted
to update.mozilla.org.
Whiteboard: In Queue
(Reporter)

Comment 12

13 years ago
Extension upgraded to 1.0.2. This is primarily a maintainance release, and
changes are limited to Javascript and one image resource.

The direct links are:

Firefox: http://www.quirk.co.za/searchstatus/searchstatus-1.0.2.xpi
Mozilla: http://www.quirk.co.za/searchstatus/searchstatusmoz-1.0.2.xpi

Thanks
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 13

13 years ago
*blush* - A user caught another small bug, so I have released version 1.0.3.

The direct links are:

Firefox: http://www.quirk.co.za/searchstatus/searchstatus-1.0.3.xpi
Mozilla: http://www.quirk.co.za/searchstatus/searchstatusmoz-1.0.3.xpi

My apologies for the double update.

Updated

13 years ago
Whiteboard: need-testing

Comment 14

13 years ago
Craig,
I see on your site that you have version 1.0.4 now.  Do you want these to be the
ones on update.mozilla.org?
(Reporter)

Comment 15

13 years ago
Yes, please. As you can see from the changenotes, the only change in version
1.0.4 was to increase the maxVersion to 1.0 to accomodate the change in the
recent nightly builds.

Comment 16

13 years ago
tested+
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041028
Firefox/1.0RC1
OS: Windows XP

tested+
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040910
OS: Windows XP

new links to .xpi's:
Firefox: http://www.quirk.co.za/searchstatus/searchstatus-1.0.4.xpi
Mozilla: http://www.quirk.co.za/searchstatus/searchstatusmoz-1.0.4.xpi
(Assignee)

Updated

13 years ago
Assignee: psychoticwolf → Bugzilla-alanjstrBugs
Status: REOPENED → NEW
(Assignee)

Comment 17

13 years ago
Please include an install.rdf (see bug 246891) with your Mozilla package.  It
will make uploading to UMO easier.  You can do that for your next release. 
Also, if the maxVer is the only thing that changes, you don't need to submit a
new XPI (in theory).

Since this is the first time we've added the Mozilla version, I'm going to
assume it's compatible with 1.7+
Severity: enhancement → normal
Status: NEW → ASSIGNED
Whiteboard: need-testing → In queue
(Assignee)

Comment 18

13 years ago
The queue has been approved.  Yay!
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
Bulk Moving Extension/Theme listing bugs to new component.
(Filter: masslistingspam)
Component: Update → Listings
Product: mozilla.org → Update
Version: other → unspecified
(Reporter)

Comment 20

13 years ago
I start with apologising for the misplacement of this message - I am hoping for
direction. 

The SearchStatus extension, which has now evolved to ver 1.1.1, has an
intermittent 'bug' which causes Firefox to crash on closing. Since this is
obviously a problem in the C code, it is not easy to determine the reason, and
after many weeks of frustration I am hoping someone here can point me in the
right direction to get to the bottom of this. 

I still have little information on the cause, apart from the data collected and
sent to talkback.mozilla.org. Please advise me on a course of action to resolve
this.

Thanks.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 21

13 years ago
You can try asking on IRC for someone to look at the talkback data.
(Assignee)

Updated

13 years ago
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
Whiteboard: In queue
(Reporter)

Comment 22

13 years ago
SearchStatus has been upgraded to version 1.2, for both Firefox and Mozilla
(Seamonkey). The direct URLs are are follows:

http://www.quirk.co.za/searchstatus/searchstatus-1.2.xpi
http://www.quirk.co.za/searchstatus/searchstatusmoz-1.2.xpi

(BTW, the issue referred to above has been identified and filed as bug 272578)

Please update accordingly, thanks.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

13 years ago
Assignee: Bugzilla-alanjstrBugs → nobody
Status: REOPENED → NEW
Whiteboard: needs testing

Comment 23

13 years ago
Tested:
FF 1.0 - Ok
MZ 1.8a5 - Ok
FF 0.8:
searchstatus-1.2.xpi - gives install error -214 and doesn't get installed
searchstatusmoz-1.2.xpi (sic!) - installs and works perfectly :))

so, I recommend tested+ anyway :)
(Reporter)

Comment 24

13 years ago
Not to be pushy or anything :), but its been a week since tested+ - any chance
of moving this on?
(Assignee)

Updated

13 years ago
Status: NEW → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
Whiteboard: needs testing
(Reporter)

Comment 25

13 years ago
SearchStatus has been upgraded to version 1.4, for both Firefox and Mozilla
Suite. The direct URLs are are follows:

http://www.quirk.co.za/searchstatus/searchstatus-1.4.xpi
http://www.quirk.co.za/searchstatus/searchstatusmoz-1.4.xpi

Please update accordingly, thanks.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 26

13 years ago
Using the anonymization makes it not work.
Assignee: nobody → Bugzilla-alanjstrBugs
Status: REOPENED → NEW
(Reporter)

Comment 27

13 years ago
SearchStatus has been upgraded to version 1.5, for both Firefox and Mozilla
Suite. The problem with the anonymization feature has been fixed, thanks for
pointing that out.

http://www.quirk.co.za/searchstatus/searchstatus-1.5.xpi
http://www.quirk.co.za/searchstatus/searchstatusmoz-1.5.xpi
(Assignee)

Updated

13 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 28

13 years ago
Your Firefox XPI says it supports Mozilla Suite.  Does it, or is the separate
XPI needed.  If so, you need to remove the Mozilla Suite section from your
firefox xpi
(Reporter)

Comment 29

13 years ago
Okay, new xpi's uploaded to the same locations with the invalid blocks removed
from the rdf files.
(Assignee)

Updated

13 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
AMO BUGSPAM FOR COMPONENT MOVE AND DELETE (FILTER ME)
Component: Listings → Web Site
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.