Reply window in plain text (s.b. html) with MS Word font/formatting garbage at top

RESOLVED WONTFIX

Status

Thunderbird
Message Compose Window
RESOLVED WONTFIX
14 years ago
14 years ago

People

(Reporter: rfb, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20040927 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20040927 Firefox/0.10

Whenever I reply to an email received since 9/25, it goes out as plain text 
even though everything I have set up says HTML, and it has this large spew of
Microsoft Outlook X-mimeOLE or possibly formatting from MS Word being used
as the person's email editor.
 
Some look like this:
> <!-- /* Font Definitions */ @font-face {font-family:Tahoma;
> panose-1:2 11 6 4 3 5 4 4 2 4; mso-font-charset:0;
> mso-generic-font-family:swiss; mso-font-pitch:variable;
> mso-font-signature:553679495 -2147483648 8 0 66047 0;} /* Style
> Definitions */ p.MsoNormal, li.MsoNormal, div.MsoNormal
> {mso-style-parent:""; margin:0in; margin-bottom:.0001pt;
> mso-pagination:widow-orphan; font-size:12.0pt; font-family:"Times New
> Roman"; mso-fareast-font-family:"Times New Roman";} h1
> {mso-style-next:Normal; margin-top:12.0pt; margin-right:0in;
> margin-bottom:3.0pt; margin-left:0in; mso-pagination:widow-orphan;
> page-break-after:avoid; mso-outline-level:1; font-size:16.0pt;
 
which appears to be MS-Word's idea of correct HTML formatting with a zillion
columns defined to micro align everything.

Other messages look like this: 
 
> Digital Systems Group, Inc. <!-- span.EMAILSTYLE17
> {mso-style-noshow:yes;} span.SPELLE {mso-spl-e:yes;} span.GRAME
> {mso-gram-e:yes;} /* Font Definitions */ @font-face
> {font-family:Tahoma; panose-1:2 11 6 4 3 5 4 4 2 4;
> mso-font-charset:0; mso-generic-font-family:swiss;
> mso-font-pitch:variable; mso-font-signature:553679495 -2147483648 8 0
> 66047 0;} @font-face {font-family:Mistral; panose-1:3 9 7 2 3 4 7 2 4
> 3; mso-font-charset:0; mso-generic-font-family:script;
> mso-font-pitch:variable; mso-font-signature:647 0 0 0 159 0;} /*
> Style Definitions */ p.MsoNormal, li.MsoNormal, div.MsoNormal
> {mso-style-parent:""; margin:0in; margin-bottom:.0001pt;
> mso-pagination:widow-orphan; font-size:12.0pt; font-family:"Times New


where they start with a &lt;span with email template, and flags for
spell and grammer checkers.  Both these messages were "in-house" from
my company, but based on the microsoft headers it goes outside and comes
back through the firewall and then distributed instead of a smart system
recognizing internal email and just routing it (possibly due to the new
spying on email introduced a while back).  The in-house domain is included
in my "use HTML" white list.
 
If I Cntl-Z in this window, it goes back to normal HTML, including my
added signature getting fixed back to HTML, but loses all the header data
except for a simple "[somebody] wrote:". I say since 9/25 because the messages 
before that were imported and have header data but it is not displayed in reply.
I don't see much of it in the other email (spam garbage). It turns the plain 
text back into HTML, but only for the first level (if there were multiple 
inclusions due to an email going back and forth, only the top level goes back
to HTML which sucks, yet another complaint).  I only noticed this problem since
I installed the last nightly release (It might be the release from 24/25th or 
from the 28th, you guys know which dates you did nightlies on). Currently,
its the 9/28 release.  I cannot force the show HTML/show plain text in the
compose window, and in the normal preview window its hard to tell if you 
are in plain/HTML mode because the button doesn't indicate which mode you
toggled to and there isn't any status symbol in the status bar for that, either
(and another complaint).

When I forward a message, it retains its HTML formatting, but it puts up
much more that a simple "somebody wrote:" or "forwarding message from somebody",
it puts out a lot of header data, sometimes all header data (can't tell the state
of a button that might have a status of which mode its in, or might be a
command to which state it will go to if pressed, that's a complaint, too). 

You need to establish a better Q.A./distribution system.  On the 
"update.mozill.org/extensions" site, even if you sort requesting only 0.8 
extensions, you get some that aren't compatible.  If you go to the homepage, 
it says updated for 0.8+, but you have to hack the install.rdf to change the 
0.7 to 0.8, and then you aren't sure which one it is really compatible with.  
Extensionroom.mozdev.org has more extensions (why?) but you have the same
problems as above but cannot sort by target release so you can't tell if it
is supposed to be for 0.8 (even if the page says it is).  I've found that
"extensionsmirror.nl" has the most, the latest extensions. How come these
cannot be in sync? (I know everyone is a volunteer, I'm not knocking you,
just questioning).  My JS Console is always spewing errors like a faucet,
"some jslib is redeclared", "some object not found", buttons don't work (the
prev/next buttons no longer work), some don't have buttons or only have buttons
that have text because the skin has the wrong path and trying to override
it in userChrome doesn't fix it.  I'll take the rest of my spew to the forums.




Reproducible: Sometimes
Steps to Reproduce:
1. open the message in preview by clicking subject (prev/next buttons broken).
2. use menu, button or right-click and choose reply-to-sender or reply-to-all
3. 

Actual Results:  
if MS outlook or MS-word used to generate message, then it flashes an html reply
and then goes to a plain text reply with things like this "<!--
span.EMAILSTYLE17" (see partials above, some are two pages long) will be there
until you do a Cntl-Z or "undo" and it goes back to the previous HTML format.

Expected Results:  
It should have not gone past the HTML display. I didn't press any other button
to make it convert to plain text.  It should have ignored the <!-- xxxxx -->,
utilized the /* Font Definitions */ and /* Style Definitions */, etc. to tell it
how to format the display of the message, not to display the formatting code!


I am using the 9/28 nightly build.  Regardless of what was thought to be fixed,
I still have many bugs: Prev/next buttons do nothing in any window. Sometimes
messages are not visible in folders unless I click back/forth between one that
looks empty and one that has contents.  Sometimes clicking Junk moves them to
local trash, sometimes to local->junk, sometimes to local->trash, sometimes to
Michael Jackson's place (Never-Never land?).  Current extensions include:
View Headers Toggle Button 1.2
Image Zoom 0.1.7
Dictionary Search 0.6.3
Buttons! 0.4.9
ForumZilla 0.5.2
Launchy 3.2.0
Quicknote 0.5.9.2
Moz Calendar 0.8+
Delete Junk Context Menu 0.3.2
Open Long Url 0.1.1
Contacts Sidebar 0.3
Timestamp 0.12
Quick Replay Extension 0.5.4
Get All Mail Button 0.0.5
Mail Redirect 0.1.3
Folderpane tools 0.0.1
No New Window on Double Click 0.1.0
Show SMTP Unsername 0.2.1
jsLib Lite 0.1.203
Toolbar Enhancements 0.16
MagicSLR US 0.7.1
Toggle Preview Pane 0.7
ChromEdit 0.1.1
AutoRewrap 0.003

Gee, now that I've gone through all the trouble of putting this report in, it is
probably something wrong with this AutoRewrap extension.  But like I said above,
you need some Q.A.  You should make sure every extension on Mozdev works without
generating any JSconsole errors (and which jsLib it requires), find out if it
interferes with other extensions or they interfere with it, and force them to
have a "help with configuration or function" file/webpage.  If it doesn't
comply, then it should be put on a blacklist so people like me know it will mess
me up if I install it.  The all need small and normal icons, they all should
ALIGN BOTTOM on text or text buttons so the display looks decent.  In this bug
report, a lot of problems are present of non-functionality of the extensions.

Comment 1

14 years ago
Bad bug report; no biscuit.

(In reply to comment #0)
Addressing the important part first:
> Gee, now that I've gone through all the trouble of putting this report in,
> it is probably something wrong with this AutoRewrap extension.  

I suspect this is correct.  Try restarting TB in safe mode and see if you get 
the same problem on replying to one of these problematic emails.  If not, please 
mark this bug as   Resolved|Invalid



> Whenever I reply to an email received since 9/25, it goes out as plain text 
> even though everything I have set up says HTML

Have you set up multiple identities?  There is a known problem with new 
identities being created without inheriting all the settings associated with the 
default identity of an account; and unfortunately, the UI only allows access to 
the default identity for most of those settings.  That's bug 246024.

But it isn't clear that it actually "goes out as plain text" because you then 
say:
> If I Cntl-Z in this window, it goes back to normal HTML, including my
> added signature getting fixed back to HTML, but loses all the header data
> except for a simple "[somebody] wrote:".

So it's actually an HTML compose window, but filled with apparently-plain text 
(a fixed-width font); and somehow, Undo causes the plain-textedness of the reply 
to disappear in favor of regular, variable-width text ("normal HTML").
Is that correct?

When the message is originally displayed, does it show as a fixed-width font?

When you type new text into the message body, does it show as a fixed-width 
font?

> I say since 9/25 because the messages before
> that were imported and have header data but it is not displayed in reply.

Imported from what -- Outlook?  Outlook Express?

> I don't see much of it in the other email (spam garbage).

Meaning you don't see the symptom on mail other than mail from work?


> [...] in the normal preview window its hard to tell if you 
> are in plain/HTML mode because the button doesn't indicate which mode you
> toggled to [...]
> I cannot force the show HTML/show plain text in the compose window, 

Meaning you *can* force it elsewhere?  Is this "button" part of an extension 
that switches between plain and HTML display?  FYI, that capability is available 
in the menus:  View | Message Body As

> there isn't any status symbol in the status bar for that, either
> (and another complaint).

You can look at that menu to determine which display mode is in use.  A status-
bar symbol for which mode might be useful to some people, but I can usually tell 
and if I can't tell, it generally doesn't matter anyway.  You can file a request 
for enhancement to add such an icon to the default build, but (if I'm right 
about the extension) you might get quicker response asking them to add that 
capability.



> When I forward a message, it retains its HTML formatting, but it puts up
> much more that a simple "somebody wrote:" or "forwarding message from
> somebody", it puts out a lot of header data

Yes, TB does that.  Whichever headers are displayed in the envelope panel are 
included in the forwarded mail.  This is not a bug, altho you could file a 
request for enhancement to suppress it.  You can delete that header material if 
you prefer.  You can also forward-as-attachment, which often is a better 
solution.



> You should make sure every extension on Mozdev works 

Uh, no.  MozDev is not a mozilla.org site, and extensions are not official 
Mozilla products -- strictly caveat downloader.  Further, bugs for them do not 
belong in Bugzilla; however, I know that at least some of the extension-writers 
have a similar bug reporting scheme, of which I invite you to avail yourself.

Writing in Bugzilla that "you should" do this and "you should" do that is an 
exercise in making yourself look lame.  If you don't like the product, don't use 
it; if instead you'd like to help make it better, submit better bug reports: 
One symptom per bug, less analysis, more facts, more paragraph breaks, and a 
whole lot less bluster.
Summary: Reply wndw in plain text (s.b. html) with MS word font/formatting garbage (X-mimeOLE) at top of message, forward wndw in html, but has header data at top. → Reply window in plain text (s.b. html) with MS Word font/formatting garbage at top
(Reporter)

Updated

14 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.