customize toolbar by command-option clicking (OS X) collapse toolbar button

RESOLVED WONTFIX

Status

()

Firefox
Toolbars and Customization
--
enhancement
RESOLVED WONTFIX
13 years ago
6 years ago

People

(Reporter: Brian Schack, Unassigned)

Tracking

(Blocks: 1 bug, {polish})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040913 Firefox/0.10

See (for example) Apple Mail for the expected behavior.

Reproducible: Always
Steps to Reproduce:
1. Hold down the command and option keys.
2. In a Firefox browser window, click the pill-shaped show/hide toolbar button
in the top-right of the window.
3. Release the command and option keys.

Actual Results:  
When the toolbar is visible, it hides the toolbar. When the toolbar is not
visible, it shows the toolbar.

Expected Results:  
It should open the user interface to customize the toolbar.

I am using the default Firefox 1.0PR theme for Mac OS X 10.2 Panther. There is
no Talkback crash ID because Firefox did not crash.
I can confirm that this is expected behavior when clicking the Toolbar Button.

On a related note holding command and hitting the Toolbar Button cycles icon
state in most applications with a Cocoa style Toolbar. It cycles between Large
icons with text -> Small Icons with Text -> Large Icons, etc.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

13 years ago
s/Mac OS X 10.2 Panther/Mac OS X 10.3 Panther/
Severity: trivial → enhancement
Summary: customize toolbar by command-option clicking pill-shaped show/hide toolbar button in top-right → customize toolbar by command-option clicking (OS X) collapse toolbar button
(Reporter)

Updated

13 years ago
Blocks: 73812

Updated

12 years ago
Assignee: bugs → nobody
QA Contact: bugzilla → toolbars

Comment 3

8 years ago
> On a related note holding command and hitting the Toolbar Button cycles icon
> state in most applications with a Cocoa style Toolbar.
Filed as bug 541399, in case anyone is interested.
Keywords: polish
Closing since this isn't valid anymore, due to the removal of the pill button in bug 573412.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
And because 10.7 got rid of the pill button in general.
You need to log in before you can comment on or make changes to this bug.