Scrollbar appears, page turns non functional

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
14 years ago

People

(Reporter: walter_ebeling, Unassigned)

Tracking

({regression})

Trunk
x86
Windows 2000
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a4) Gecko/20040927 MultiZilla/1.6.4.0b
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a4) Gecko/20040927 MultiZilla/1.6.4.0b

After using the vertical scrollbar to go to the end of the "Angebote" section of
the web site, a new horizontal scrollbar appears and disables the vertical scrollbar

!! This is one of the biggest german retailers 

Reproducible: Always
Steps to Reproduce:
1.Open www.aldi-essen.de
2.Go to Menue "Aldi Aktuell", left corner
3. Select first menue entry "ab 6.10.04" , the date may vary
4. An new page with the sales offers appears, showing vertical and horizontal
scrollbars
5. scroll to the end of the offer section
6. an new horizontal bar appears
7. vertical scrollbar becomes shorter and doesn't work



Expected Results:  
Should work

This is a regression.The site worked with 1.7.2.
(Reporter)

Comment 1

14 years ago
Created attachment 160716 [details]
Screenshot of the issue
(Reporter)

Comment 2

14 years ago
similar issue bug 260980 ??
Blocks: 261196

Comment 3

14 years ago
With 1.8a4 I see a second set of scrollbars appearing as soon as the frame with
sales offers is focused by clicking somewhere in the frame area or by using one
of the scrollbars. Afterwards the frame is scrollable with those two new
scrollbars. 

This bug was not reproducible with Gecko/20040702.

Comment 4

14 years ago
Created attachment 160816 [details]
Testcase - Frame document

This is the first part of a simplified testcase.

Comment 5

14 years ago
Created attachment 160817 [details]
Testcase - Frame content

This is the second part of a simplified testcase. 

Save both attachments to the same directory and open AEtestcase.htm, focus the
frame by clicking or scrolling and a second set of scrollbars should appear.

Comment 6

14 years ago
wfm Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8a5) Gecko/20041001

there are two sets of scrollbars, the outer belonging to the frameset, and the
inner belonging to the frame. When the page is loaded, you only see the outer
ones. If you use the (outer) scrollbar to scroll to the right, the inner
vertical scrollbar gets visible. You can use this inner scrollbar to scroll
through the frame.

now the text I´ve written before finding the solution above, don´t know if it is
of any use:


seen on Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.2) Gecko/20040803
Mozilla 1.4.2, current nightly, 
Mozilla/5.0 (Windows; U; Win98; rv:1.7.3) Gecko/20040911 Firefox/0.10
Netscape 4.79 was crashing, Opera was showing as intended.

Comment 0 states it was working with Mozilla 1.7.2, but I´m seeing the bug on
Mozilla 1.7.2, rarely used profile (for tests with 1.7.2)
As I´m seeing this bug also on Mozilla 1.4.2, I don´t think it to be a
regression. The website is unusable, imho. Validator was showing only three
bugs, after setting encoding to ISO-8859-1.
Maybe it depends on screen resolution, I´m on 800x600.



For our non-german-speaking friends:
1. load http://www.aldi-essen.de/
2. click on 'ALDI aktuell' (top left)
Frame http://www.aldi-essen.de/OFFER_D/index.htm ois loaded.
If you load it in a new tab, you can scroll vertically and horizontal.
The frame has 6 rows each one holding 5 images, and the heigth of the frame is
about 120% of the height of a row. (rough guess)

Comment 7

14 years ago
Opera is showing same behaviour as Mozilla. At first you only see the outer
scrollbars, and when the inner horizontal scrollbar comes up, it blocks further
vertical scrolling. You must use the outer horizontal scrollbar to scroll right
to get the inner vertical scrollbar visible, but as you are very low on the
page, and the inner scroller is at the top of the inner scrollbar, the only
thing visible of the inner scrollbar is the bottom arrow button.

The website seems to be technically correct, though imho visually unusable.
Another design error at http://www.aldi-nord.de/ = http://www.aldi-essen.de/
is, that they splitted one image to use it as background in two frames,
http://www.aldi-essen.de/IMAGES/homepage_main.jpg
http://www.aldi-nord.de/IMAGES/homepage_unt_li.jpg
Using full screen, you see it correctly, normal display hides the bottom of the
upper image, so the cars in the lower image don´t get their top from the frame
above, but the roof of the shopping center.
The other one of the biggest retailers, http://www.aldi-sued.de/ has same
problems with the frames on the start page, but not in the products page.
SÜD is only partially shown. ( german 'sued' = 'süd' means south, not related to
the english 'sued')

Can anybody tell which Mozilla was working better than the current ones,
and what exactly 'better' means?
(Reporter)

Comment 8

14 years ago
To answer the question, this is working correctly with  Mozilla 1.7.1
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.1) Gecko/20040707
MultiZilla/1.6.3.0e.

Correctly working means IMHO that only one vertical and one horizontal scrollbar
is visible and allows to scroll though the whole sub screen.

Comment 9

14 years ago
With Mozilla 1.8a4 and a screen resolution of 1024x768 or higher, after focusing
the frame (a dotted outline appears around the frame), the original scrollbars
grow a little larger and a second set of inner scrollbars is created (but not
yet visible). You have to use the outer scrollbars to see this new set of
scrollbars.

With Mozilla 1.7.3/Firefox 0.10.1 and a screen resolution of 1024x768 or higher
there is only one set of scrollbars, scrolling the sales offers frame as
expected. No confusing, second set of scrollbars appears when you focus the frame. 

With a screen resolution of 800x600 (or by resizing the browser window) the two
sets of scrollbars are already there without focusing the frame.

Updated

14 years ago
Keywords: regression

Comment 10

14 years ago
Mozilla Windows Trunk Nightly Build Regression Window
Pass: 2004090105
Fail: 2004090206
(Reporter)

Comment 11

14 years ago
Works with Mozilla 1.8a5 and Firefox 1.0 RC2

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8a5) Gecko/20041103
MultiZilla/1.6.4.0b
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Clicking on an overflow:auto div doesn't focus it anymore. That behavior was
changed by bug 262578.
But overflow:auto divs are still focusable by tabbing through them.
So, I can still reproduce the bug when I'm tabbing through that page, although
the effect of it is now not that serious anymore.
Severity: major → normal
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 13

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050428
Firefox/1.0+

WFM.
I can't reproduce with a build with the fix for bug 240276. It could be that
this was already not seen anymore on the ur, but bug 240276 should have fixed it
otherwise, probably.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.