Build fails with Binutils version 2.15.91

RESOLVED FIXED

Status

()

RESOLVED FIXED
14 years ago
14 years ago

People

(Reporter: shreevidhu2001, Assigned: dbradley)

Tracking

Trunk
x86
Windows 2000
Points:
---
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR 1.1.4322)
Build Identifier: 

I followed all the steps in http://www.mozilla.org/build/win32.html

And regarding the tools i'm using mingw gcc/binutils:

binutils-2.15.91-20040904-1, gcc-core-3.3.3-20040217-1 ,
gcc-g++-3.3.3-20040217-1,
mingw-runtime-3.3 , w32api-2.5.

My mozset.bat(to set environmental variables).

set MOZ_TOOLS=c:\mozilla\moztools
set MOZCONFIG=c:\mozilla\mozilla\mymozconfig.mozconfig
set PATH=c:\mozilla\mingw\bin;c:\cygwin\bin;%MOZ_TOOLS%\bin;%PATH
set HOME=c:\mozilla

My mozconfig is:

CC=gcc
CXX=g++
CPP=cpp
AS=as
LD=ld
ac_add_options --disable-accessibility
ac_add_options --enable-debug
ac_add_options --disable-optimize


when trying to run make -f client.mk build_all from command prompt
got the compilation errors as in the attached document.

I think its a new bug with the binutils version 2.15.91

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

14 years ago
Created attachment 160735 [details]
Build Log
*** Bug 261761 has been marked as a duplicate of this bug. ***
Assignee: general → dbradley
Component: Browser-General → XPConnect
QA Contact: general → pschwartau

Comment 3

14 years ago
I also have this problem. I identified it as being caused by the following two
lines:

#137: ".type  " SYMBOL_UNDERSCORE "_XPTC_InvokeByIndex,@function\n"

#197: ".size " SYMBOL_UNDERSCORE "_XPTC_InvokeByIndex, . -" SYMBOL_UNDERSCORE
"_XPTC_InvokeByIndex\n\t"



I am using binutils-2.15.91-20040904-1 as well, with gcc-core-3.4.2-20040916-1,
gcc-g++-3.4.2-20040916-1, mingw-runtime-3.5, and w32api-3.1

Comment 4

14 years ago
Also, I'm using Windows XP and attempting to build Firefox.

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

14 years ago
Created attachment 160885 [details] [diff] [review]
Remove .type & .size for win32

Not sure if this is a problem for non-win32 builds or not but we don't seem to
be using the proper format for .type & .size.  Per the warnings that we've been
seeing forever, mingw binutils expects those to be inside .def/.endef blocks. 
This patch removes their use for win32 completely.

Updated

14 years ago
Attachment #160885 - Flags: review?(dmose)

Updated

14 years ago
Flags: blocking-aviary1.0?

Comment 6

14 years ago
not sure we would block on this, but go ahead and get it in in the next few days.
'thanks
Flags: blocking-aviary1.0? → blocking-aviary1.0-

Updated

14 years ago
Attachment #160885 - Flags: superreview?(dbradley)
(Assignee)

Comment 7

14 years ago
cls, I'm not a super reviewer. I don't mind reviewing it.

Comment 8

14 years ago
Comment on attachment 160885 [details] [diff] [review]
Remove .type & .size for win32

r+sr=dmose; sorry for the delay
Attachment #160885 - Flags: superreview?(dbradley)
Attachment #160885 - Flags: superreview+
Attachment #160885 - Flags: review?(dmose)
Attachment #160885 - Flags: review+

Updated

14 years ago
Attachment #160885 - Flags: approval1.7.x?
Attachment #160885 - Flags: approval-aviary?

Comment 9

14 years ago
Comment on attachment 160885 [details] [diff] [review]
Remove .type & .size for win32

a=asa for checkin to branches.
Attachment #160885 - Flags: approval1.7.x?
Attachment #160885 - Flags: approval1.7.x+
Attachment #160885 - Flags: approval-aviary?
Attachment #160885 - Flags: approval-aviary+

Comment 10

14 years ago
Patch has been checked into the trunk, 1.7 & aviary branches.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 11

14 years ago
Shouldn't it have the keyword for being fixed on Aviary as well?

Comment 12

14 years ago
This bug seems to have an aviary branch checkin associated with it. If this has
landed on the aviary branch (as much as it's going to for 1.0) can you please
add the "fixed-aviary1.0" keyword? Thanks.
You need to log in before you can comment on or make changes to this bug.