REQ: automatically detect an exact RSS feed link for Life Bookmark

RESOLVED WONTFIX

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED WONTFIX
14 years ago
12 years ago

People

(Reporter: Rimas Kudelis, Assigned: vlad)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2) Gecko/20040819 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2) Gecko/20040819 Firefox/0.9.1+

It would be nice to be able to enter the website URL into "Feed location" field,
and o have Firefox detect the correct RSS link automagically, when <link
rel="alternate" ..... > links are provided. And only if that fails, Firefox
should say that "Life bookmark failed to load". That should probably be done
when adding it, so that we don't need to parse the whole webpage each and every
time the browser is run.

Reproducible: Always
Steps to Reproduce:
Run Firefox
choose "Manage bookmarks", File > New life bookmark...
and enter a URL of the website of which you know to provide an "alternate"
<link> element.
Click OK and close bookmark manager
open the bookmarks menu and scroll to the new life bookmark item
Actual Results:  
The item either remains as "Life bookmark loading...", or says "Life bookmark
failed to load"

Expected Results:  
Firefox should detect an "alternate" <link> element, and follow it.
we already parse the entire page to lay it out, its trivial to grab any
appropriate link tag after that, and give the user the option to add the feed
directly.  Why we would add a function that basically invisibly loads the page,
then parses it, then adds the live bookmark instead of just offering the option
in the context of browsing the page is beyond me.  Other than loading the page
anyway, how are you going to know whether there's a link element anyway?  And if
you went to the trouble of FINDING that via View Source, you could just copy the
feed URL from the tag anyway.  And maybe the kicker is, 99% of our users
probably don't know how to find a valid link tag on their own, so its not
something that belongs in the core since its a generally useless concept.

"Live bookmark failed to load" is due to connection/parsing issues just as
often, so I'm not sure what your point was there.

This is more complex and has no perf/usability advantage over being able to add
feeds while on the site.  In fact, its more complex and more code.

WONTFIX.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

14 years ago
what i ment was that maybe FFox should not trust that _entered_ link blindly, 
but should insted check it and see, if it's really an RSS feed, and if it's 
not, then check wether it's an HTML page providing an alternate link.

For me personally, it's not hard to find that RSS link, no matter if it's a 
banner, or a <link> element. However, not every average user can read HTML, 
imho. This feature would help such users.
(In reply to comment #2)
> For me personally, it's not hard to find that RSS link, no matter if it's a 
> banner, or a <link> element. However, not every average user can read HTML, 
> imho. This feature would help such users.

What Mike is saying is that you can right click on any such element and select
"Copy Link Location", and then paste it in the new Live Bookmark dialog (liVe
btw, not liFe).  No need to read HTML.
(Reporter)

Comment 4

14 years ago
I completely agree with that, but the thing is that "Add New live bookmark..." 
dialog (the one reacheable via bookmarks manager) currently presumes that you 
already KNOW the exact location of an RSS feed. However, you may not always 
know it (i.e., you may have forgotten it or whatever), plus, some average user 
without knowledge about what exactly an RSS feed is, may think "i want to see 
all the news from site X in my bookmarks" and try to add a live bookmark to 
site X, without digging a lot and searching for an appropriate RSS feed link.

Even for me it would be easier to add LB's without first looking at the site 
itself and copying the link from it.

that was just a feature request anyways. And sorry for the typo. :)
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
(Reporter)

Updated

12 years ago
Duplicate of this bug: 262443
You need to log in before you can comment on or make changes to this bug.