Crash checking for updates

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: jimdigriz, Assigned: bugs)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

Talkback ID TB1064226H
Firefox Crash when checking for updates.
Didn't find a duplicate in Bugzilla.
Don't know if this should be under the extensions manager or perferences.

Reproducible: Didn't try
Steps to Reproduce:
1. Tools -> Options -> Advanced -> Software Update -> Check Now
2.
3.

Actual Results:  
Crash followed by Talkback starting up.

Expected Results:  
Check for updates?
(Reporter)

Comment 1

14 years ago
Cannot reproduce. Restarted Firefox. Checked for updates again.
Updates Available were:
1. Quality Feedback Agent
2. DOM Inspector
3. Two Themes from ftp.mozilla.org (Doodle Plastik 1.5.9.1 & Doodle Classic 1.5.9)
4. One Extension from downloads.mozdev.org - EM Buttons 0.12.4

All installed successfully.

Leaving this open until someone has a look at the talkback data.

JdG
(Reporter)

Comment 2

14 years ago
How many times does Firefox 0.10 want me to install the same updates on the same
day? "Updates Available"; "Installing Doodle Classic 1.5.9" followed by "Firefox
could not install this item because "install-pi.rdf (provided by the item) is
malformed. Please contact the author about this problem".  Could this be the
cause of the crash originally?

OK. In the theme manager I now seem to have both Win32 and Mac versions of
Doodle Plastik and Doodle Classic. Can installing the Mac version of a theme on
a Win32 platform cause a crash?

Comment 3

14 years ago
Not reproducable.

Please report the Doodle problem in separate bug against mozilla.org/Update,
it's their problem (most probably).

Did it crash before or after showing the window with available updated components? 
Severity: minor → critical
Component: Extension/Theme Manager → Software Update
Keywords: crash
Summary: CRASH Firefox Extension Manager Check for Updates → Crash checking for updates
(Reporter)

Comment 4

14 years ago
> Did it crash before or after showing the window with available
> updated components? 

Before.  This was the first time I used the check for updates functionality and
it crashed almost immediately before giving me a list of updates to install. 
Perhaps it only fails at the first attempt?  I'm going to mark this WFM since I
can't reproduce this crash.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.