Pithy 0.2 - Reclaiming the Page-Info key.

RESOLVED INVALID

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED INVALID
13 years ago
2 years ago

People

(Reporter: Rowne-Wuff Mastaile, Assigned: Jed B)

Tracking

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040927 Incredi-shrew-mole/1.0 X (Firefox/1.0PR [nightlies] polymorph)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040927 Incredi-shrew-mole/1.0 X (Firefox/1.0PR [nightlies] polymorph)

This is my first time filing a request for an extension of my own to be listed
at UMO, so forgive me if I've done this incorrectly.

That said...

"Pithy (v0.2 Fx0.9-1.0)

This extension restores the Page-Info hotkey that went missing in recent Firefox
builds, it does this by disabling the secondary bookmark key and using that for
Page-Info instead.  This hotkey is called [Accel]+[I], which is [Ctrl]+[I] on a
PC keyboard or [Command]+[I] on a Macintosh."

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Updated

13 years ago
Assignee: psychoticwolf → jedsbugs
(Assignee)

Updated

13 years ago
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 1

13 years ago
I can't get to the file, can you either host it somewhere else or attache it?
Thanks
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> I can't get to the file, can you either host it somewhere else or attache it?
> Thanks

A thousand pardons, it appears as though my ISP went down sometime last night, I
see a good number of reconnection attempts in my logs and I've been offline for
a while.  Thusly, my site should now be accessible again but I'll create an
attachment anyway, sorry.
(Reporter)

Comment 3

13 years ago
Created attachment 161241 [details]
Pithy 0.2
(Assignee)

Comment 4

13 years ago
No problem.
Howevere you install.rdf seems to be malformed.
See: http://jedbrown.net/mozilla/EM/
for more info.

Marking invalid, please reopen when fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

13 years ago
(In reply to comment #4)
> No problem.
> Howevere you install.rdf seems to be malformed.
> See: http://jedbrown.net/mozilla/EM/
> for more info.
> 
> Marking invalid, please reopen when fixed.

Will do!  I looked over the site though and I can only see two potential issues.

1) The pro-GUID stance.

If I need a true-GUID I'll include one.

2) <maxVersion>1.0</maxVersion>

Should it be a maximum of 0.10.1?

That's all I can think of.  Everything else matches the spec personally.  I
thought 1.0 wasn't unreasonable though and the use of Named-IDs over GUIDs was
just personal choice, I didn't realize it would classify the install.rdf as
malformed.

If it's not either of these, could you be more specific?

Comment 6

13 years ago
A real guid is needed, as firefox uses it internally for a variety of things.
including extension update and chrome. :-)

MaxVersion should be 0.10 not 0.10.1 (the latter is a application version, the
extension compatibility version for 0.10.1 is still 0.10 :-) ) 

-- Wolf
(Reporter)

Comment 7

13 years ago
Created attachment 161349 [details]
Pithy 0.2 install.rdf altered to meet U.M.O spec.

Updated

13 years ago
Component: Update → Listings
Product: mozilla.org → Update
Version: other → unspecified
AMO BUGSPAM FOR COMPONENT MOVE AND DELETE (FILTER ME)
Component: Listings → Web Site
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.