Closed Bug 262558 Opened 15 years ago Closed 15 years ago

FF 0.10.1 patch (software update) does not clear update button for non-root / normal user (installs with wrong permissions)

Categories

(Toolkit :: Application Update, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: pauldavid_johnson, Assigned: bugs)

References

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10.1

My Firefox 0.10 is installed in /user/lib and so any patches - like 259708.xpi -
has to be installed by root. When I installed this patch using Firefox running
as root, it installed it sucessfully (see install.log portion below). 
The problem is that the two files are installed with permisisons read only for
root. 
This means that the patch does not work when I am running firefox in my normal
user. I had to do a chmod of the two files concern to read for other user and
group users before the patch would work for my normal user.

-------------------------------------------------------------------------------
http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/0.10.1/patches/259708.xpi
 --  2004-10-02 10:37:56
-------------------------------------------------------------------------------

     Patch for bug 259708 (version 1.0.0.0)
     --------------------

     [1/2]	Replacing: /usr/lib/firefox-1.0/components/nsHelperAppDlg.js
     [2/2]	Installing: /usr/lib/firefox-1.0/defaults/pref/bug259708.js

     Install completed successfully  --  2004-10-02 10:37:56


Reproducible: Always
Steps to Reproduce:
Install patch on a computer that requires root to update firefox

Actual Results:  
When running firefox as root - we are running firefox 0.10.1
When running it as another user - we are running firefox 0.10

Expected Results:  
Firefox 0.10.1 should always be running
URL: N.A.
I can confirm this on Slackware 9 with Firefox installed in /opt/www/firefox
owned by root:root.  I installed this update via Firefox update as root and
everything went fine.  I too had to chmod those two files as r for everyone for
the update to work correctly.

Additionally, I had to modify two settings in about:config under my normal
account to get Firefox to recognize that the update had taken place.  The two
settings were:

  - "app.version" -> "0.10.1"
  - "general.useragent.vendorSub" -> "0.10.1"

After these two steps everything seems to be A-OK.

Thanx!
  Richard
*** Bug 262637 has been marked as a duplicate of this bug. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Patch that upgrades to 0.10.1 installs with wrong permissions → FF 0.10.1 patch (software update) does not clear update button for non-root / normal user (installs with wrong permissions)
As root, I ran firefox and installed the update.  There does not seem to be a
way to do this as a normal user - tried several times and got a permission
denied error since it was trying to modify files that were not owned by the
normal user.

After I installed the update, as a normal user, the version would always be
0.10.0.  As root, the version would be 0.10.1 when I ran firefox.

Since root installed the update:
misfits# pwd
/usr/local/firefox-1.0PR/defaults/pref
misfits# ls -ltr
total 28
16 -rw-r--r--  1 root root 14906 Sep 14 01:16 firefox.js
 4 drwxr-xr-x  5 root root  4096 Sep 17 21:59 ../
 4 -r--------  1 root root   149 Oct  1 13:59 bug259708.js
 4 drwxr-xr-x  2 root root  4096 Oct  3 22:13 ./

misfits# chmod og+r bug259708.js 
misfits# ls -ltr
total 28
16 -rw-r--r--  1 root root 14906 Sep 14 01:16 firefox.js
 4 drwxr-xr-x  5 root root  4096 Sep 17 21:59 ../
 4 -r--r--r--  1 root root   149 Oct  1 13:59 bug259708.js
 4 drwxr-xr-x  2 root root  4096 Oct  3 22:13 ./

Now, the version is 0.10.1 when I run firefox as a normal user, and the update
indicator is off.
looking at the 259708.xpi

c:\tmp>testzip.py 259708.xpi
-- ZipFilename: 259708.xpi --
Name: nsHelperAppDlg.js
O.S.: 11 Unknown
Attr: 32
Perm: 400

Name: install.js
O.S.: 11 Unknown
Attr: 32
Perm: 400

Name: bug259708.js
O.S.: 11 Unknown
Attr: 32
Perm: 400

Realy the file was packed with the pemissions r---------.
See also bug #189905 about prefs of unpacking files.
*** Bug 262653 has been marked as a duplicate of this bug. ***
*** Bug 262604 has been marked as a duplicate of this bug. ***
*** Bug 262579 has been marked as a duplicate of this bug. ***
*** Bug 262825 has been marked as a duplicate of this bug. ***
I think that this problem is a problem which can arise not only Linux but OSX
and Windows(2000/XP).
*** Bug 262581 has been marked as a duplicate of this bug. ***
Flags: blocking-aviary1.0?
I can confirm Greg Hankin's comments (#3) below for Redhat Linux 9 and Fedora
Core 1, both updated with all Redhat/Fedora updates as of 10/6/2004, running on
Intel hardware.  The Fedora machine is running a customized 2.4.26 kernel. 
Firefox on both is installed in \usr\local\lib\firefox\.  Chmod
./defaults/pref/bug259708.js to 444 permissions, and the user-run firefox works
as updated on both PCs.  I should say that firefox is run from a soft link
(/usr/bin/firefox) to /usr/local/lib/firefox/firefox.
Flags: blocking-aviary1.0? → blocking-aviary1.0-
Flags: blocking-aviary1.1+
Whiteboard: [asaP1]
Flags: blocking-aviary1.1+ → blocking-aviary1.1-
Is this still a problem with the new update system? 
Whiteboard: [asaP1]
Yes, this bug no longer applies to the new update service.  Marking INVALID.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → INVALID
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.